SmartThings Community

Wemo Dimmer - Smart Things - Fed up

I’ve searched high and low for information on how to make the Wemo Dimmer Switch work with Smart Things. There are a bunch of posts that seem to indicate that people have written device handlers and a bunch of responses indicating how difficult it is to get them working. Then there are also a bunch of posts and responses indicating that there is absolutely no support for the Wemo Dimmer Switch. Smart things is supposed to be the platform where you can write device handlers and smart apps for any IoT device. I’m pretty sure the Wemo Dimmer Switch has been out for years now. What is the big deal? Why exactly … is it impossible to get this device to work with Smart Things … especially when the rest of the Wemo Devices has everything necessary in Samsung Labs.

I’m beginning to get fed up with Belkin, and I’m definitely getting fed up with Smart Things.

WiFi devices can often be handled by Smartthings, but not directly.

There are many good reasons to get annoyed with Samsung, and with their management of Smartthings. But don’t get mad over something you are presuming should be, when it never was claimed to be.

Instead, feel free to write the device handler!

1 Like

Please see [RELEASE] Wemo WiFi Smart Dimmer … I just released and have been using it successfully for a few days now.

Smartthings works mostly with zigbee and zwave devices. Wifi is a whole other animal requiring work to write to many different device APIs instead of the standardized zigbee and zwave protocols.

Did you see anywhere advertising that this particular dimmer works with SmartThings (besides user posts)?

Sirtwist, I will take a look and try to install it tonight.

Davin, I did not see it advertised as working. However, there is a ton of expectation around being able to create device handlers for pretty much any IoT device in Smart Things. I also had another regular wemo wifi switch and because of Samsung Labs, it picked up and worked wonderfully, so a very natural expectation would be that the dimmer would work along with the other wemo products they got to work. Which as you know is not the case, so I then expected to go and find another device handler to make it work. But after a week of searching and seeing that people who were previously successful had now taken their handlers down, I became a little fed up / annoyed because it seemed this impossible hill to climb when the notion of this whole thing is supposed to be fairly easy.

Thanks for the advice Glen. However in my research it seemed like it was not possible and that many people had tried. And some people had previous handlers, that they removed from github or at least I have not been able to find them. I’ve looked at the documentation, there’s a ton of it and trying to parse through what is good and what is not and working through the tutorials (that don’t exist) feels like that’s months of work. Also even being a pretty experienced developer (15yrs) learning how to write a handler for dimmer when others had tried and failed didn’t seem like a good waste of my time.

For those that stumble upon this thread, I have successfully (so far) installed @sirtwist smart app and device handler. It was easy to do an has worked.

I have used Sirtwist’s method successfully for a few weeks. However, just like all the solutions to this problem, it eventually breaks when some complex/unexpected pattern of events occur; in such a case, re-doing the whole thing helps. Another, more annoying breakdown happens when Wemo sends a firmware update to these switches; usually a new firmware is utterly incompatible with the device handler + smartapp. The developer of the smartapp has better things to do than track Wemo’s updates. Samsung really needs to include the dimmer in its “labs”. This is ridiculous.

1 Like

Oddly enough, while @sirtwist’s smartapp+device-handler stopped working sometime in March, and then I haven’t seen any update from him, I had given up on this, never bothered to tinker with it, just left it as is.

Strangely yesterday, the 18th of June 2019, I noticed it was ALL working. Can’t think of anything that changed. There was an update on my phone to the wemo app, but that can’t be it.

I guess I had a one second power outage in the morning. That rebooted all the dimmers, the smartthings hub and everything else). So I am not sure which device’s reboot (dimmers or the hub) fixed it, but as I am typing this, all the wemo dimmers are working through smartthings, and all the automations/lighting smart app rules are running successfully.

1 Like