Weird ST app behavior adding Linkind Matter device

Getting some weird behavior on the Android SmartThings app trying to add a Matter bulb. This is SmartThings app v1.8.07.23 and the app reports it is the latest version. Running on Galaxy S21.

Adding starts out normally - I scan the QR code on the bulb and switch it on. The app reports the device is recognized and runs through the “Getting set up” dialog. Eventually asks me to set up the network and this is where it gets weird.

EVERY network it finds is reported as running WEP. Problem is none of my networks, nor any of those in range hosted by neighbors, runs WEP. But it doesn’t matter which network is selected, all of them result in the following error:

I was able to find an old post from 2015 that mentioned this behavior but the poster said they entered the password and it all worked great. Of course, at the time they weren’t adding a Matter device but enrolling a hub. I wonder whether it worked for them because the hub recognized the WPA2 but not for me because what is being passed tells the bulb it’s WEP when it isn’t. Anyway, that’s just a theory and not at all the weirdest thing it’s doing.

No, the award for weirdest behavior is that when entering the password for the network, the app is arbitrarily picky about how many characters it can be. The “Connect” button is grayed out until you get to 5 characters, at which point it activates. But then it is gray again from 6-9 characters, activating at 10. Then gray at 11 and 12, but active at 13.

Just for kicks I changed the Wi-Fi password to 13 characters which allowed me to hit Connect, but it then fails and goes back to the QR code scanner page.

“There’s an app for that!”
The bulb is from Linkind and they want the user to install the AIDot app to do the enrollment and then link accounts. But the thing that attracted me to Matter in the first place is that - theoretically - it isn’t necessary to run a boatload of apps. And, in fact, when I go to the SmartThings “Add Partner Devices” page and click Linkind it invites the user to link accounts or enroll directly.

So I’d really like to get it to work in the SmartThings app and even if I could get them enrolled through the AIDot app it seems like the ST app behavior is too weird not to be a bug. It should be able to tell the difference between WPA* vs WEP even on a bad day, and it should allow any number of characters in a password.

Anybody seen this before? Have I managed to botch the install or does this look like a bug? (At this point I’d rather learn I botched the install because at least there would be a quick fix for that scenario.)

Thanks

1 Like

I’m sure that’s very frustrating. :disappointed_relieved:

Two thoughts:

  1. what model is your SmartThings/Aeotec hub, and what firmware level is it at?

  2. Does your WiFi support IPv6 addresses? This is a requirement for all Matter devices.

Meross support explains this issue.

(Note that the report image on that page is just an example, you have to follow the link to get the report for your network.)

If the link on that page doesn’t work (it gets overloaded sometimes), Google also offers a test page, although their report is just a yes/no indicator.

https://ipv6test.google.com/

1 Like

JD, I have s question. At camp my internet service provider does not provide IPv6 but I have been able to add Wiz Matter bulbs. How is that possible.

2 Likes

AeotecHubVer

Firmware version: 000.049.00009

A Thread network identifier is displayed and when navigating to the device page the Zigbee, Z-Wave and Matter logos are displayed.

That question turns out to be more interesting than it should be. An IPv6 address is assigned to my laptop when logged onto the same Wi-Fi router as the hub, and that Wi-Fi router reports it has an IPv6 assignment from the cable router. But when I go to the Google page I get the same result as @Paul_Oliver and the whatismyv6 page times out.

Just for grins I installed AiDot on an old phone handset and installed the bulb that way. That worked and I was able to link accounts, but since it is using the vendor’s service and cloud I have no idea whether it has provisioned or is using IPv6 and I doubt it is using Matter since it isn’t assigned to a SmartThings hub.

So I have some homework in front of me today. The easiest test is probably to temporarily reconfigure the hub to connect direct to the cable modem. If that doesn’t work I can connect the laptop there and dig into the v6 details. But at least I have a place to start so thanks for that!

1 Like

Many IPv4 routers are able to spoof IPv6 support, so it sounds like that’s what you have at camp.

There are a couple of different ways of doing this, some more elegant than others, but mostly you don’t have to worry about it. If you get an OK from a IPv6 check page like the Google page, you shouldn’t have to worry about what’s inside the black box. :sunglasses:

@nathancu @Automated_House

BTW, if you’re curious, this is what the Google check page looks like if your router does support IPv6.

3 Likes

Thanks. I figured you would have the answer.

1 Like

SmartThings’ Matter implementation requires that you have a SmartThings/Aeotec hub or one of the newest Samsung refrigerator/TV dongles. Samsung implemented Matter using edge drivers, and that’s what edge drivers run on.

FAQ: What do I need to add a Matter device to the SmartThings app? Do I need a bridge router device?

Thanks. I do have the Aeotec hub but what I was referring to was that after the ST app weirdness, I enrolled the light into AiDot then linked the accounts just to see if I could get it to work. At that point, it showed up in the ST app but not assigned to any hub. Thus, I guessed it didn’t magically connect using matter once the accounts were linked, but rather remains an AiDot cloud device on plain old Wi-Fi.

As soon as I get my router set up with IPv6 I’ll try the ST app again. I’ve been trying to preserve the network isolation I had with IPv4 so it’s been a bit slow going as I climb that learning curve. I might just temporarily set it up to relay IPv6 DHCP back to the cable modem for testing, then go back to trying to isolate it.

1 Like

Correct. To use the Matter integration, you must select that option in the app. It’s up to each user which integration method they want to use if more than one is offered, there’s no automatic priority for matter. I personally think that’s a good thing, the choice should be the user’s, particularly since different integration methods will offer different functionality.

For example, right now if you have a SmartThings/Aeotec hub, you can add a Philips hue bridge in any of 4 ways:

  1. cloud to cloud (“linked services”)
  2. stock LAN integration
  3. stock Matter integration
  4. community-created custom integration

The user has to choose which integration method they want to use when adding the device. But again, I personally think that’s a good thing. :sunglasses:

1 Like

Hey @iopt were you finally able to integrate the matter bulb to your ST? I had exacty the same weird behavior with the app saying my wifi is WEP protected (who uses WEP nowadays? btw) when trying to add a matter color bulb.
Yesterday I tried again after a few weeks and now I was able to do it without a problem. It seems the problem was corrected either with an app update or the new v50 firmware, or both.

1 Like

Not quite yet. I did learn a lot about IPV6 in the meantime and bottom line is I’m redesigning my network. Formerly I had all my local VLANs behind my own router which sat behind the cable router. Getting the internal router to both subscribe to and serve IPV6 DHCP was the issue. Now I’ll run the IoT VLAN off the vendor’s router and all the file service. printer, and laptop off the internal router. There will be a DMZ

In the meantime, we closed on the new house and I had just set up the new network topology when I got appendicitis with some complications and here we are. I did get as far as confirming that I now get routable external IPV6 for new devices but not tried that AiDot bulb again. The plan now is to get moved in and then pick this all back up.

The surgery was done by a robot, by the way. They didn’t even bother to put googly eyes on it to make it look relatable.

1 Like

Interesting. Sounds like there was a lot of research involved! I do wonder how many people trying matter are going to run into something IPv6-related, although most will probably have simpler setups than yours.

@Automated_House @nathancu @HalD @orangebucket @AlejandroPadilla

3 Likes