Unable to onboard Meross MSS115 Smart plugs to ST Station

I have a pair of Matter enabled Meross MSS115 Smart plugs that I’d like to onboard to my Samsung Smartthings Station (EP-P9500, latest firmware).

The Smartthings app detects the plug as soon as it powers up. When I walk through the steps of adding it, my device (tried this on my phone - S22 Ultra and my tablet S8 Ultra) it eventually times out with an error 39-101.

The only way I’ve figured out how to control this from the Smartthings app is to add the MSS115 to the Meross app. Then link Smartthings to the Meross app.

That’s just a pain. And I’m not sure if the plugs will still work if I’m not at home with my device since the hub does not appear to be controlling the automation.

Is there any way to link these plugs directly to the Smartthings Station?

(Withdrawn by author)

Yes, it is. It literally has the Matter logo right smack on the front of it.


My bad, my first post was an error. I was looking for the European model number, but it looks like that one is also Matter enabled.

So it should work locally with the station as long as you have updated the station to the most recent firmware.

@Automated_House might know more.

I updated the firmware to P9500XXU1AWB1 this evening after unboxing it.

No worries, Meross is a mess on their models and it took them over a month to even get back to me on my order status. So far, I’m not impressed with them or their product.

I use quite a few Meross devices, and like them a lot. They work well with HomeKit and OK with smartthings. Good engineering, good safety certifications, great prices, but I definitely agree Customer service is pretty sketchy.

There are also quite a few glitches in the initial smartthings matter implementation, so I don’t know if that has anything to do with it. That’s why I tagged Jimmy, he’s been trying quite a bunch of different devices including the Station.

Ok. Thank you for your help.

1 Like

Overnight, my S22 Ultra got an update.

I tried to onboard the Meross after the update. The behavior is slightly different. Now, instead of it saying connecting it says preparing.

But, ultimately, it still fails. But with an error code of 05-300.

I forgot to mention that out of home control of Meross devices added with the cloud to cloud method work just fine as long as your home has active Internet, so the Meross devices can reach their own cloud. The automations run in the smartthings cloud, not on your hub, anyway. So that’s not an issue regardless of which way you connect them.

A couple things to try:

  1. Make sure your home networking equipment has ipV6 enabled
  2. If you can, temporarily disable your 5ghz and 6 ghz wifi bands.
1 Like

IPv6 isn’t a thing for my ISP. IPv4 only.

1 Like

Matter requires IPv6. All Matter devices.

(Note that the big number code that Meross shows on this support page is only a picture example, you have to actually follow the link they give you to order to test your own network.)

There are some IPv4 WiFi routers that can spoof IPv6 addresses for your local network, which can solve the issue for thread devices, but it may not solve the issue for WiFi, and Meross has not given any indication that it will for theirs. And even with thread, you might lose some group multicast messages. :thinking:

So, in this case, Meross is following the standard required to use the Matter logo, but I know that doesn’t help. :disappointed_relieved:


Really? Then why does it work when I use the Meross only app? Or when I bind the ST app to the Meross app?

IPv6 requirements seems kind of limiting. IPv6 is hardly a globally deployed standard. Especially out in the sticks where I am.

The devices on my network can build and talk over the link local addresses. But without getting into a very complex IPv4-6 tunnel, IPv6 to the internet is simply not happening.

Seems to me that if v6 is indeed a mandatory requirement then lots of people are going to struggle deploying what should essentially be a plug and play kinda thing.

1 Like

Because that method is not using Matter addressing.

Seems to me that if v6 is indeed a mandatory requirement then lots of people are going to struggle deploying what should essentially be a plug and play kinda thing.

Yeah, a lot of people have said the same thing, and the industry seems to be waiting to see what happens.

Matter is the first widely deployed consumer standard to require IPv6. I personally think it should be a big requirements box on anything with the matter logo, but they’ve decided not to do that, at least for now.

Jon Smirl has been bringing up this issue for at least six months, but no one else seems to be highlighting it. See the comments section to the following blog article:

5 ways Matter will disappoint users at launch - Stacey on IoT | Internet of Things news and analysis

1 Like

Well, that’s just the stupidest, dumbest thing I’ve heard in a long time.

Don’t get me wrong, I’m pro-v6. But it’s just not there for something that bills itself as the end-all-be-all of simplicity.

I’m confused. If this is a Matter device and the Meross app/ST is the Matter controller, then it seems to me v6 would need to be in place. At the very least, link local addressing.

What is the big deal when switching this to a strict ST controller only suddenly force the v6 thing? None of it makes sense.

Link local v6 addresses are available on my network. But going to the internet via v6 is a non-starter. And I’ve talked to engineers at my ISP (it’s a small little back-woods outfit and it’s easy to find the folks who know what’s what) and there are no immediate plans to enable v6.

This discussion seems to indicate Matter does not require IPv6:

So this is Meross forcing v6? That would have been nice to know before buying them.

That would work for a thread border router, I just don’t know if it works with WiFi matter devices.

I don’t know if @Automated_House has looked into it or not.

As for why it works with the non-matter integration, I’m confused about why you’re confused. :thinking: Lots of devices support multiple protocols. I would guess, although I don’t know for sure, that the regular nonMatter Wi-Fi connection that you are using for the cloud to cloud integration is IPv4. There’s no reason it has to be the same as the matter connection.

Not just Meross. Anything available for sale using the matter logo will use IPv6. Jon Smirl has built some of his own non-certified Matter devices strictly for his own use, but you’ll notice even he is using IPv6 now.

1 Like

I’m confused because the Meross plugs work when I use the Meross app. They also work when I bind the ST app on my phone to the Meross app.

Where the problem of confusion comes in is when I try to bind the plugs directly to the ST app.

I don’t believe these plugs are Thread enabled. Are they?

So I guess my questions are:

When does IPv6 become a hard requirement?
Is it when Thread is in use?
When the Meross plugs try to talk to my ST Station, is Thread trying to be used and that’s why it is broken?
Do the Meross plugs actually use Thread?
When does the Matter protocol actually get used? Anytime the plugs want to talk to a controller?

So far, I’m giving this whole thing a big giant thumbs down.

The MSS115 is a Wi-Fi device. Nothing to do with thread.

But just as with Zigbee, Wi-Fi can now have multiple profiles. And those profiles can have different addressing formats.

So it’s entirely possible that a Wi-Fi device being connected using Meross’ normal Wi-Fi profile is using IPv4 addressing, while communications using the Matter profile uses IPv6.

Communication using the cloud to cloud integration between meross and Smartthings doesn’t care how the MeRoss device is communicating to its own cloud: smartthings is not addressing the Meross device directly in that case.

As for when IPv6 is required for an WiFi end device under matter, it is required to be certified to use the Matter logo for sale to consumers.

This thing is going to be a dud from the get-go.

1 Like