Website password reset - Server Error

Is anyone else getting a 500 server error when attempting to reset their password on the website (not the community site, but the actual Smartthings website)? I’ve been trying to reset my password all morning to check the status of my order but get the following error:

I’ve submitted a ticket to but I figured I’d check with the community to see if I’m the only one getting it. I’ve tried Firefox, Chrome and IE on Windows 7 and Windows 10 with the same result, so I’m pretty sure it’s not my connection (I even tried Chrome on my Nexus 5 while connected to just LTE).

1 Like

I have the same problem :frowning:

Same here… opened ticket since Friday and not resolved yet

Having same problem and since I ain’t found a phone number for tech support I thought I’d find the answer here! Sadly it seems not! :frowning:

I get the following and am desperate to resolve the issue!

Oh No! Something Went Wrong!
500: Internal Server Error
Reference Id
Thu Nov 19 21:54:44 UTC 2015

Please Help??

Thanks in anticipation!