Can't log in to SmartThings

I just got my Smartthings v2 this week on Tuesday. It was great until I couldn’t log in to use it anymore. Wondering if anyone else has had this problem, as support has been no help at all. I’ve had a ticket open Sept 30th and still no resolution.

Here are my sequence of events:

  1. Log in to smartthings app
  2. Logged in to
  3. Tried to log in to from another computer, but I forgot my password
  4. Created account on using “sign in using Google account”
  5. Signed out of smartthings app on phone to see what my username was in the app. I thought that would be the same username to log in to
  6. I see that my username is my email address, and attempt a password reset on the ST phone app and
  7. Got this message: “Forgot Password
    Your password reset email was sent to: “*****” - check your mail! If you do not receive it in a few minutes, verify your address was typed correctly and try again.”

Now the problem is that the password reset email never arrives. Anyone know how I can fix this? I have no control over any of my connected devices because of this problem…surely I’m not the only one that has ran into this issue.

I’ve asked for an update from Support but so far they have failed to respond or resolve the issue.

Your community password is separate. Try this link

@Tyler_Milam, user names for the Community are different than the developer site and app.

Try the forgot password again and make sure it’s not going to spam, trash, etc. Unfortunately ST support is the only ones who can help since this is an account issue.

@jodyalbritton thank you, that is a perfectly reasonable suggestion. Either something is going on with their password reset functionality, or my account is borked.

I get the message that an email has been sent to me with a password reset, but it never actually comes. That’s as far as I’ve gotten with support so far. Surely I’m not the only one having an issue if the password reset send function is down.

The reason I mentioned the community account/password is that I thought there may have been some kind of cross authentication garbling…if the community logon and ST app logon were linked in a way.

@johnconstantelo - support advised I check my spam folder. Nothing there :frowning:

At this point I’m thinking about making up a new email address, using that to make a new smartthings account, and factory resetting my ST v2 hub.

To reset your hub you first have to remove it from your old account, which you cannot do at this point. One possibility is that your email address could be wrong in your account. Either way, if you are not getting your emails, support is the only option you have left.

Oh well…thanks for the tip. You’ve saved me some time on frivolous attempts to fix this myself.

Well, here’s what I can contribute… The SmartThings development is broken and disjointed. I recently bought a Google Home and it seems to work perfectly. That’s where I was introduced to this concept of “SmartThings”. Discovered that my Honeywell 9000 series WiFi thermostat is supposedly SmatThings compliant, so naturally the techy part of me attempts to add it as a device; so I begin to do this through my phone. SmartThings on the phone naturally wants me to log in to add a SmartThings device. Cant do it… Not registered… No way to register from my phone, only log in or reset the password for an existing account. So intuitively I proceed to their website and register and do so successfully. Go back to my phone to login to SmartThings, it has no idea who I am. 24hrs later, it still has no idea who I am. I do the password reset thing from the phone and never receive and email, junk spam or otherwise. Another 24hrs later, same old same old. I begin a web search as to why this would be and land here; at this forum. Had to make a different registration for here. Will have to wait until I get home to see if the phone will let me in there using this registration.

Hi Mike,

Sorry for the trouble! Have you contacted our support team (live chat or email) on They should be able to get you sorted quickly.

This thread is over a year old and related to something completely different.


1 Like

I had the same issue. Tried multiple accounts, with multiple password resets. I could log into just fine, but not the app. It turned out to be special characters in the password tripping up the app. Change your password to something without special characters.

This is really a dumb problem to have for the app, and hope someone sees this and resolves it soon.

Cannot believe how awful SmartThings auth is. Logged in on app, no problem; logged in on graph/dev site, no problem; try single sign on, never works.

Add me to the list of individuals for whom the password reset link does nothing. The email simply never comes.