WebCore Newbie Issue

webcore

#1

Hi, I am completely new to the world of smartthings and by no means a code writer! I have been playing about with Webcore Pistons and writen a few useful pistons for my home. I am however having a recurring issue with one that I have written to bring on some home lights slowly in the mornings at a set time.

The issue I am having is that all seems to work well when I first set the piston, for about a week, then one day it will just start all lights switching on and off at the start time trigger rather than dimming up. This not a fast strobe, just a regular on and off ever second or so. If I delete the piston and re-write and set, it all starts running properly again. It seems to be related to the timer function?

Any clues as to where I have gone wrong, as my wife is seariously unimpressed with our new early morning slow disco! Thanks!


(jkp) #2

Please attach a screenshot of the piston. You can create one by clicking on the green camera icon on the piston. Also, you should explore the WebCORE community forum at https://community,WebCORE.co

Bam! Now your screenshot appears :slight_smile:


(jkp) #3

You may want to remove only while night in the dimming line. You are setting the mode to home immediately after which will cancel out the command above.


#4

Cheers @jkp

I have removed the only while night in the dimming line. When saved and went back to the piston list the trigger count down timers were running again, which is good as they had disapeared which presumably was also part of the issue.

I have been lurking about the WebCORE community forum for info and generally working out how to programme pistons. This is all new to me!

Thanks for your help, hopefully no more slow-stobe wake ups. :crossed_fingers:


(Sully) #5

Just to throw this out there, because there’s half a dozen ways to do things… Here’s another way of writing that piston:

Uses a timer and restrictions, instead of the if statement… I’ve got something similar set up for a couple of things. Though, I haven’t tried fading for that length of time. I went ahead and set the task cancellation policy to never because of the time frame… Anywho, just a thought.