webCoRE - Global time variable issue


(Florin Angelescu) #1

Hi there,

I have an issue with a global time variable that I am trying to use.
I have created the variable and set a value to it: 7:00 AM
Then I have a routine that it is supposed to execute each day at that time. The thing is that the routine gets to execute at 5:00 AM instead. I am guessing this has something to do with the GMT settings.
How can I set the variable so that it should execute at 7:00 AM local time?
Please don’t reply saying to change the hour to 9:00 AM - this is not a solution, it’s a workaround.

PS: I don’t have the same issue if the variable is local…

Thank you,
Florin


(Bob) #2

Why dont you use ‘Time’ instead of a variable.


(Florin Angelescu) #3

Because I am using it in multiple pistons and when I will decide to change its value I want to change it only in one place.


( I hate Mondays) #4

Is your computer’s timezone set to the same timezone of the hub, I am guessing EEST, currently at GMT+3 due to DST?


(Florin Angelescu) #5

Yes, same timezone. :frowning:
It’s weird that local variables perform fine.


( I hate Mondays) #6

I will look into it when I get home.


( I hate Mondays) #7

Ok, found the bug - the set variable in the UI was setting the variable to UTC time, rather than local, but the SmartApp code expected local time. Hard reload your browser and reset the global variable, it should then be ok.


( Cosmo) #8

Me too, mine is firing an hour off.
My hub time is “Arizona/Phoenix”

Webcore is firing off of a mountain (daylight) time.

AZ is its own timezone though matches Pacific during Daylight savings, and Mountain during standard time.
All devices that modify WC pistons are properly set to AZ timezone.

Ideas @ady624?


(Florin Angelescu) #9

After the latest update the time difference is now shifted: before it used to trigger 3 hours earlier, now it triggers 3 hours later.


( I hate Mondays) #10

You need to go to the global variable and re-edit it. set it to what you want, again.


(Florin Angelescu) #11

Unfortunately, I get the same behavior. I even created a new variable, but it is still doesn’t working.
If I setup the time variable value to 7 AM for example, after saving the variable it will show 10 AM as the value set. :frowning: