Water Cop shutoff Valve


(Brian Spranger) #1

Hi I have installed a second Water Cop shutoff valve and the device is working but the DH is not updating its state properly.

The device is sending the event to the DH and the DH logs the even but then the state does not change.

I can control the device from Webcore just fine.

The first Water Cop I have works fine. It is using the same DH and its states update as expected.

Here is a screen capture of the state showing open, but in the event it shows it closed (which it did).

Here is the event.

I am using the built in Fortrezz Water Valve DH for both devices.

I have excluded the 2nd device and re-paired it, and I get the same result.

I am on the classic app with Android.

Does anyone have any idea what may be happening?


(Tony Fleisher) #2

Maybe a UI issue with the app. Have you tried forcing the app to restart and see if it displays correctly?


(Eric) #3

in my experience, the most common reason for the indicated status of a physical device to not reflect actual, is lack of signal. But I would not expect commands to work at all.

I would try anyway:

  1. repair mesh network ( phone-app/ Hub/ ZwaveUtilities/ Repair,

  2. add Zwave repeaters/plug-ins, and REPAIR MESH again.

  3. changing orientation and height of hub can change propagation. I would also consider moving the hub away from any radio emitters, even though Wifi should be irrelevant to Zwave.


(Brian Spranger) #4

I have tried to do a zwave repair. It did not help.

I don’t think it is a mesh issue. I have a lot of zwave dimmers which repeat and they are a long way from the hub and working fine.

The two water valves are the closest zwave devices I have and they are within 10 feet.

The valve is working fine. It is just the UI in the app that is not updating.


(Eric) #5

compare the devices details in IDE


(Brian Spranger) #6

I have done that too and have not noticed and differences.


(Eric) #7

ok - I got nothing new. Maybe file a support case.

If it was my equipment, I would add repeaters, and move the hub, and repair the mesh. Signal propagation responds to more than just distance from the hub. Also I might swap the actuators to see the problem moves or changes.

Good luck. Please post followup if you work it out.


(Jimmy) #8

have you tried the default z-wave water valve device handler?


(Ted Tapeworm) #9

I had the exact same issue and can offer some insight. In short, I believe it is an issue with a recent update to the SmartThings Classic app, but that it will work perfectly with the new SmartThings app.

Here’s a detailed version: I have the genuine Fortrezz version of the shutoff valve. It had functioned flawlessly for over 2 years. Then around early July 2018 it started misbehaving, exactly as you describe.

The “Recently” tab shows the correct state of the device, but the “Right Now” tab does not. I tried re-pairing the device and rebuilding the network. I also moved the hub right next to the valve. It would work briefly after re-pairing, say for 10 minutes at most, then fail. Most commonly, once closed it would show the valve as open and would not respond to commands, but its behavior was inconsistent, in that it invariably would fail to respond to commands from the app in either the open or closed position. Manually (by pressing the buttons), it operated correctly. I had been using the classic app. I don’t even know what Webcore is, so obviously I was not using it. However, I had the valve connected to several smart apps including leak detectors, presence detectors, and the Fortrezz flow detector.

The device is installed in a vacation home 1,000 miles away, so I could only work on it intermittently. It was very frustrating.

I had decided that the physical device itself must have gone bad and resigned myself to replacing it. Surprisingly, when I checked Amazon, I saw that the WaterCop, which looks nearly identical (except for the built in water sensor) was a small fraction of the cost of the Fortrezz, so I ordered two of them (one with and one without the brass valve, as backups).

Since I will not be at the vacation home for some time, when the new WaterCop valves arrived, I actually built a test network at my present remote location, setting up a new Hub (v2), new SmartThings account, and adding each of the two new valves into the network one-by-one, as the only device. (The Fortrezz device at the vacation house is installed in a crawl space, so the test setup was a lot more convenient.)

The two new WaterCops behaved exactly the same as the Fortrezz using the classic app (either iPhone or Android version). While I had not yet received an invitation to upgrade to the new app, just for kicks, I installed the Android version of the new app. Lo and behold, on my test account, it automatically detected both new WaterCop valves and they both work just fine now.

So, I guess what I’ll need to do is migrate everything over to the new app. I will only do this when I am at the vacation home because, right now, the valve is stuck in the open position and water is needed there for the irrigation system. I don’t wish to risk having the valve getting stuck in the closed position (although I risk the possibility of a leak developing with no way to turn off the water).

Long story in short: given that the Fortrezz valve had worked perfectly for two years, my valve started failing around the same time as yours and that the two new WaterCop valves I tested work fine with the new app but fail with the classic app (even though it logs the history correctly), I conclude that there is a fresh bug in the classic app.

Hope this helps.


(JIm) #10

There is another thread about this issue. Mine still works fine, I can open/close from the classic app, but the tile always says open. The recent history is correct. I tried the default Z-wave water valve DTH and it didn’t work at all. The new app does show the correct position. And ActionTiles also works fine.


(Brian Spranger) #11

I have not migrated since I have over 30 Xiaomi sensors, and other custom DHs.

It is so strange that one of the water cops work fine and the other does not.


(Andrew Mc Grath) #12

This has to be a Smartthings device handler issue. The history showing one thing, but the button showing another should be all the evidence we need to produce.

I have the exact same issue with two of these valves and really want it fixed. Am I just going to write my own handler or will the Smartthings team get their act together and deal with this?