Vivint Thermostat

So I am a new smarthub user. The house I have came with the Vivint element thermostat v-sct200 and it is zwave plus but I cant get the smartthings to find it. Just thought I would ask if there is even a way to do this.

Thanks

I did a quick search and found this: (specifically post #10)

If you haven’t excluded your thermostat from your Vivint controller, you’ll need to do that first, and then try joining it to SmartThings.

Did you get a solution to this. I have been trying the for the last day, cant seem to get ST to copy the ZWave nodes from Vivint, after following instructions found on this site.

To remove the thermostats from the Vivint panel, I ran the remove node on the Vivint panel and removed my thermostats. This is done by going to the installer menu 2203 pin after pressing the software version on the Vivint panel, and menu on the element thermostat can be accessed by pressing the button on side for a few seconds (I felt more than 3 but instructions state 3), keep it pressed and the menu will pop up. Select network on the menu and select disconnect. Now if you don’t have the panel you may need to reset the thermostat, instructions at the end of this post.

Next, to add the thermostat to ST, start the add things routine on the ST classic app and now on the element panel you can select connect in the network sub menu. The thermostat is detected as a CT100 Thermostat and not CT200 as it should be. It seems to work but commands from the ST app take a long time to relay. The Vivint panel copies the node added to the ST hub and shows also as CT100, however changes from the panel are readily accepted.

Interestingly enough, when I first joined the ST hub to the Vivint Panel, I added as a node (not as a controller, because it would not find it).

Contrary to instructions I have seen on this forum, and the ST hub quickly started showing all devices already on the vivint panel with existing nodes and devices were readily accepting commands from the ST app. All except for one mini plug (which now I think is malfunctioning anyway). The elements thermostats copied over again as CT100 Thermostats which I could rename.

Since then I have reset the ST hub, excluded all devices from the Vivint panel and added the ST hub as the first Zwave device to the Vivint panel i.e Node 2. I have done this process two times now and find that when adding devices back to the Vivint panel, only Node 3 device is copied by ST and node 4 onward are not. So I removed all nodes 4 onward from Vivint and added them to ST and could see all of them appear on Vivint except my mini plugs (Darn it!).

So I feel, instructions for adding ST to Vivint, should state that all devices that you absolutely want to remain on Vivint (such as security related, locks, motion sensors etc) should be added to vivint panel before adding the ST hub to as the last node added to Vivint, and the rest of the z-wave devices to should be added to ST.

Hope this helps I would like to hear your experience with the setup and behavior after inclusion into ST.

Factory Reset Instructions for Element Thermostat:
Use this procedure only in the event that the network primary
controller is missing or otherwise inoperable.

  1. From the Home screen, press and hold the SIDE button for three (3) seconds.
  2. Press DOWN to highlight Installer, then press the SIDE button.
  3. Press DOWN to highlight Reset, then press the SIDE button.
  4. Press DOWN to highlight Reset, then press the SIDE button.
  5. To confirm that you want to reset the device to factory defaults, press DOWN to highlight Reset, then press the SIDE button.
    The device resets itself and reboots. You will need to connect the device to your Z-Wave Network and specify your system’s equipment and settings. See the Installation Guide Setup section.

My goal is to completely get away from Vivint and use only ST. I’ve removed almost all my z-wave devices from the Vivint panel. I’m trying to get the Element thermostat to join to my ST hub. It’s obviously not listed, and I’ve tried a few of the listed thermostats but after the ST z-wave connects, it won’t communicate with ST again or it’s just not the right device.
I guess my question is, can the element thermostat be used independently with ST hub or am I going to have to buy a new thermostat?
FYI, I’ve reset and disconnected the z-wave network on the thermostat before trying to connect to ST.

I went through trial and error for two weeks before my Vivint Kwikset Locks and Element thermostats connected. Here’s what not many know I guess, the Vivint panel has a antitheft setting and when it is activated on the door locks and thermostats it prevents them from completing the pairing process. Even with factory resets on the locks and thermostats. You have to unpair from the Vivint panel first. I factory reset my locks and thermostats, added each one back to the Vivint panel and made sure the anti theft option was turned off, the panel automatically offers this option when I paired my devices, then removed from Vivint panel. Once that was completed they all connected to ST hub as they should have. I did each device one at a time, not sure it matters, I deactivated my Vivint Sky Control Panel and uninstalled it and I’m still under their service for a few months too. The only device I haven’t reused is the doorbell which I replaced with the $100 Ring. Have the panel in the garage to tinker with now.

1 Like

Taylor (all),

I also have Vivint panel. Are you using any Vivint security features, or just locks, lights and switches? Are you monitored by Vivint without using the Vivint panel?

I was planning to make my smartthings hub a secondary to my Vivint or vice versa depending on which is best.

Thanks in advance for feedback!

Trey,

I’m not really using any of the Security features. Our contract isn’t up until October of 2019 but I disagree with being locked out of a $600 (whatever the cost) panel that I paid for, then told what I can use with it, and then have to ask permission to use it while being mounted on a wall in my house. This arrangement was not explained to me when purchasing the system. So, I have service but not using it.

For emergency services Fire, Police, and Medical I have Z-Wave smoke detectors, will incorporate a panel/panic button along with a cellular backup. There is also newer technology out and on the way for medical monitoring or for personal safety monitoring if needed. I don’t plan on having any security monitoring services in the future either.
I’m also reconfiguring my whole smart home setup to be ran locally keeping the Z-Wave devices and moving to a whole home control setup. Mostly for monitoring and home control.

I have added all the door sensors and motion sensors back to the Vivint Panel and made the Vivint Sky Panel a secondary to my Smart Things hub and also have Fire 10 and 7 tablets setup using action tiles as my GUI/dashboard. The Vivint panel seems a little buggy as the secondary panel but I connected it more or less for fun. Also the Vivint Panel is not connected to my network and lacks the ability to use the cellular antenna now.
The sensors are easy to setup and connect and seems to work locally fine, logging with audible alerts if desired. The Vivint cameras I really don’t have a use for but the ping cameras connected back to the panel and I was able use too. Everything Z-Wave I moved over to Smart Things and has worked great.

Thanks Taylor. Sorry it took me so long to get back.

Trey

sorry for dragging up an old post, but i am desperate in trying to find a solution here.

we had been vivint customers for almost 2 years until one of their installers who was attempting to install a new camera, completely borked our system (i honestly believe it was the firmware update he ran, but they claim it was something else). they sent out 5 different installers over the course of 3 weeks and eventually just gave up and without any warning or notice - shut off our system, came and got all the panels and cameras, and refunded me for everything.

the 2 thermostats i have (the element v-sct200) still functions fine as a stand alone thermostat… but i have been unable to get it to do anything. it is “supposedly” removed from their network, but i have no panel to test it with or verify. but i cannot get this new smart things hub to detect it at all when i try to add it. it will add successfully to my ring security system, but i cant do anything with it there (and i have removed it from ring after trying).

not sure what else to try here. im really not looking forward to replacing $300-400 worth of thermostats… but need SOMETHING to connect to this thing. any help or suggestions appreciated.

well, nevermind. turns out i was doing everything correctly… the hub was screwed up. zwave was set to inactive, and wouldnt turn on. shows an update failure a million times in the log. think i need something a little more dependable.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.