3M-50 Wireless Thermostat


(Jeff DeWolfe) #1

Hello All-

Myself and a few people I work with have a 3M-50 Wireless thermostat. We were all hoping that this might be able to tie into SmartThings somehow. Any ideas on it are welcome. Let me know if there is any way I can help in getting it to work.

 

Thanks!


(Andrew Urman) #2

Nice. Z-Wave has a high rate of compatibility. I’ll put it on our “to buy” list to be sure. But I’d say with confidence that the with the Z-Wave U-Snap module, it has a high degree of out of the box compatibility.


(Jeff DeWolfe) #3

Thank you for the update!!! Glad it somewhat works. I hope with some more playing around and maybe reaching out to the devs we can work out the bugs. Please me/us update on this!


(Andrew Urman) #4

A lot of times Z-Wave devices need to be given commands and told how to report back and respond. I’ll take a look at the command sheet for it and add it to the next firmware stack.


(Jeff DeWolfe) #5

Thanks Andrew! Looks like I should start shopping for the module!


(Andrew Urman) #6

Our support for thermostats is going to mature a lot, and is somewhat difficult since so many thermostats support many different functions. It’s just a matter ironing out the details.

Feedback like this is suuuper supportive.


(Jeff DeWolfe) #7

I don’t have the zwave module yet, but please let me know if there is any sort of testing that I can help out with.


(David Simmons) #8

Does the hub support url? I have this thermostat also and would like to continue using it.
All the functions can be control via curl, does the hub support this?
http://www.radiothermostat.com/documents/RTCOAWiFIAPIV1_3.pdf


(Coolcatiger) #9

I bought http://www.ebay.com/itm/251237531811?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1439.l2649
and out it in empty slot on the side.
Steps.

  1. Remove batteries
  2. Power off HVAC completely.
  3. Insert zwave module.
  4. Put batteries . power on
  5. Go to set up and put thermostat in pairing mode for the the slot 1 or 2 in which you have put zwave usnap.
  6. Press add button on the app.

It will show up on the app as thermostat.

With this both wifi and zwave work simultaneously.

Only problem I have now is - some times due to zwave card the internal programmed schedule stops working.


(Dan Lieberman) #10

@techiedavid - In a future firmware update to the hub, it will become possible to issue HTTP commands from SmartApps running in the SmartThings Cloud to devices on the same local network as the hub. Once this capability is implemented, you should be able to write a SmartApp that implements the Radio Thermostat API to talk to your thermostat.


(Jeff DeWolfe) #11

I finally ordered the zwave usnap module. It should arrive this Saturday. Sounds like SmartThings improved the usage with it as my friend has the same setup. I’m hoping it works well!


(Coolcatiger) #12

After I put usnap module, the internal programmed shcedule does not work 90% of the time. I am not able able to fgure out in what instance it works. I though ST was sending some command but removed the thermostat from ST hub , kept the module inside the thermostat and tested. Same issue. Let me know if you face same issue. I have 3 of these and they all behave same, one works 20% of time and one fails most of the time.


(Chrisb) #13

coolcatiger… it’s a stretch, but have you tried removing the module, deleting the programming, re-installing the module and then re-reprogramming?

I know on my Kwikset door lever they warned that any codes entered prior to installing the Z-Wave module wouldn’t work anymore. If I had to guess I would say they are forcing codes to be entered AFTER the z-wave module is installed to ensure that the module knows about all the codes. That way there isn’t some phantom code that will open the door that a owner doesn’t know about because Z-wave interface doesn’t know bout it.

Obviously this is for my door handle, not your thermostat. But the same principle might apply here. They want to make sure any programming put in the zwave module knows about, so any previous programming might not work exactly as intended. Like I said, it’s a long shot, but something to perhaps try if you haven’t already done so.


(Jeremy Whittaker) #14

@coolcatiger I followed these steps exactly and my SmartThings app will not detect my ZWAVE module in my 3M-50. Did you have to do anything tricky to get it in initialize mode? I’m basically clicking on the radio antenna icon, clicking on the number radio at the top(1) and then selecting the mate button. I wait in my smart things app but it never detects anything. I also have the wireless module in there. Not sure if this is conflicting or not.

  1. Remove batteries
  2. Power off HVAC completely.
  3. Insert zwave module.
  4. Put batteries . power on
  5. Go to set up and put thermostat in pairing mode for the the slot 1 or 2 in which you have put zwave usnap.
  6. Press add button on the app.

(Jeremy Whittaker) #15

I’m really hoping someone can help me out here as I’ve now purchased 2 ZWAVE usnap modules and neither of them work.

These are the steps I’m following:

  1. Disconnect thermostat C cable and take out batteries.
  2. Put in ZWAVE usnap module.
  3. Power it back on.
  4. Go into ST app and click the + button to add a device, it says searching.
  5. On the thermostat go to menu click the radio icon.
  6. Click the link button under the radio icon so that it is blinking.

I’m pretty sure that this point ST is supposed to find the module.

I’ve even gone as far as disconnecting my ST hub and moving it right next to the thermostat.
Completely reset the thermostat to defaults.
Hit the reset button multiple times.
Purchased 2 ZWAVE snap modules
I have the 802.11 usnap module which I’ve installed in both usnap ports to confirm they are good in my thermostat. It always works without a hiccup.

Any ideas on what I can try next here? I’m fresh out of options. Is anyone sure that they’ve actually paired a 3M-50 & ZWAVE usnap module to ST hub? Please help.


(Jeff DeWolfe) #16

Hello- Yes, I currently have my 3M-50 paired to my SmartThings hub. I actually have the wireless module in slot 1 and the ZWAVE module in slot 2. Both work and I can control it from either the radio thermostat app or from the SmartThings app. I’m pretty sure that I followed all of the same steps you have taken. I don’t remember doing anything in addition to that. The only thing I would say is that it took a while to get the readings from the thermostat once it was added. Since then though, it seems to work almost better than the radio thermostat app. Sometimes bit quirky on getting it to change through the modes, but that is all. The one and only other complaint is that the sliders for setting temps are difficult to use.


(Jeremy Whittaker) #17

Well, I cannot get this thing to work for the life of me. After the second Zwave USNAP I’m throwing in the towel.


(Andrew Urman) #18

You shouldn’t give up because it should totally work. Try putting the hub in Z-Wave remove mode then clicking the link button and see if the USNAP modules were removed. If it works then try pairing again.


(Jeremy Whittaker) #19

@urman thanks this is exactly what the problem was. Since I purchased this device used on Ebay it was already paired to another ZWAVE hub.

However, per ST technical support I logged into ide.smartthings.com to try and put my hub in exclude mode. I than almost instantly began initiating the command from my thermostat to try and send it the exclude command. It would never work. Luckily I had an old cheap battery ZWAVE controller laying around. I was able to send the exclude command from this device pretty easily and it worked instantly. I then was able to include the ZWAVE USNAP module on my ST hub.

Thanks again for all the tips!


(Andrew Urman) #20

ah sorry @jeremywhittaker the Z-Wave Exclude button on the IDE is broken :frowning: Slated for a Monday fix.