Vision Z-Wave Rely (Dual)

Usage Issues (for Installation see Device Ideas)

I have installed the Vision Z-Wave Dual Relay. They worked well with Wink, and using Nomadtech’s Vision Dual Relay DH, it worked well for switching using the buttons on the interface.

Issues started when I tried to use the Automation & Smart Apps… ST stopped turning on my lights at sunset and off at sunrise.

Now as of April 13, one of the switches remains on all the time. I can’t use the light switch or my phone app to turn off switch 1. Switch 2 is working from phone app and light switch. I assume i have a bad relay, that is stuck closed.

has anyone else had this issue? should I replace with the same relay? (it is small enough to tuck inside the dual gang box, behind the light switches. Is there a more reliable, but small device I should replace this with?

How many lights are you trying to control with the relay? Are they LEDs, CFL or incandescent?

Switch 2 (the working one) has a single 60W incandescent

Switch 1 (the one that is stuck on) has 4 of the candelabra type bulbs 12W. A total of 48W incandescent.


Load (wattage) has nothing to do with this. It’s a relay.
Your problem sounds like somehow the parent got deleted and you have only children left. Check in the automation/smartapp section if you have Virtual Device Sync active for this. It’s what created children devices. If not, get it here
You might need to remove everything related, do a device exclusion, repair your relay and redo Virtual Device Sync.

Thanks, I will try it tonight and provide an update.

NomadTech - I verified that the DH fo the relay was the same as the one from your setup post, and the Virtual Device Sync is setup in the Apps. I can confirm it is no longer “being used” by my relay though. I will completely remove the devise, delate all, then rebuild from scratch. i will update once that is done this weekend.

Since the load does flow through the device, i am still skeptical… but will take your word for it.

It has been a long time since I posted this issue and replacing my vision dual relay with a new one fixed my issue. Upon further troubleshooting, the vision dual relay failed one of the relays, and is now a vision single relay. I post again, since this just happened for the second time a month ago. I have replaced with a Enerwave RSM2 Dual Relay Switch which does work really well (needs specific Handler though), hoping it will last longer than the 6-8 months i have been getting.