Vision ZWave Relays

Anyone know why the vision single and dual relays (ZL7431 / ZL7432) stopped selling on Amazon? I really like these parts because they are so easy to use and pretty low cost. Are they being discontinued or something?

Thanks,

  • Ryan

No idea, maybe they’re getting a zwave plus model ready. But that’s just a guess.

Some of the specialty retailers still have them, like @TheSmartestHouse

https://www.thesmartesthouse.com/collections/vision

2 Likes

These look like the same ones sold by Monoprice.com too.

The older Z-Wave chip used in these relays is getting phased out so the products are being discontinued. The single relay is in low stock and we don’t know if/when it will be replaced with a Z-Wave Plus version. The double relay is still in stock on our website and will probably be replaced with a Z-Wave Plus version in August/September.

In the meantime, we really recommend checking out the Qubino modules which are much more advanced than the Vision ones in terms of software and the number of supported types of electrical loads but they’re equally small (and thinner).
Here is the single relay: https://www.thesmartesthouse.com/products/qubino-z-wave-plus-flush-1-relay-module-zmnhad3

And here is the double relay: https://www.thesmartesthouse.com/products/qubino-z-wave-plus-flush-2-relay-module-zmnhbd3

4 Likes

Thanks this is helpful information. The Qubino modules look nice, but I wish they weren’t double the price.

1 Like

No problem Ryan. You can always reach out to our customer service to request a custom quote if you’re looking to buy 5 or more. We’ll be happy to give you a discount on the devices!

3 Likes

So if I try to “Include” this on SmartThings V2 Hub in 2019 it won’t work if the Hub is running latest software?

I’ve tried everything imaginable and it just does not seem to be jiving 100%. It clicks relay once, but won’t ever respond to anything again after that first click

I can easily exclude / include it as many times as I want.

I’m really really getting frustrated. Purchased these from you guys back in 2016. Used them effortlessly in my SmartThings V2 Hub back then… but since then I’ve now accidentally removed my Hub from my account and decided to go through entire house and exclude/include them again… I’m now back to a Fresh Hub with some of the device handlers I once used… which worked fine before but now do not seem to work.

Any tips would be soooo helpful as I’m about to lose my crap.

Thanks!

Did you transfer from the Classic app to the new app as well? Have you checked in the IDE portal that the correct device handler is assigned to the relays?

Yeah, I’ve done all of that. Tried every possible device handler from the past as well as from the forums here… :-/

It’s possible that there is a bug in the recent ST firmware release causing this issue. They’ve been struggling with support for multichannel devices. We’d recommend waiting until the next firmware update to see if you get the same results.