Virtual switches are not showing up in new app.

I am working with 2 different phones; both iPhone. One phone is running the app before the last update to the app, and the other one running the new update.

With the new update none of the virtual switches are showing up when trying to create an automation based on device status.

In the old app all the virtual switches are showing up fine when trying to create an automation.

In both apps if you list devices they are showing up just fine.

I have tried going into the Groovy ID and they are showing up there also.

I called Samsung and they confirmed the exact issue. They escalated the call. Is anyone else running into the same issue?

Working fine here in Android. Are they maybe already used in another automation?

Yes I am having the same issue. Also in the new version the virtual devices don’t show up in scenes or automations. Many things seem to have broken since the recent update, I am still troubleshooting but it appears virtual devices are not working. I am using Apple products.

Plenty of users are reporting similar items in the latest iPhone app… Join the discussion here:

SmartThings iOS client 1.6.59 (January 25, 2021) - Apps & Clients / iOS - SmartThings Community


Was virtual switches removed from the ST app for Android? It is Jan. 15, 2023, and it is still not an option.

Edit: nvm. I found it: Menu - Lab - Virtual Switches.

Or use user created virtual switches, some of the developers have created excellent alternative virtual switches with many more options and work localy

1 Like