Virtual Switch Creation: Access Denied


(Lewis) #1

HI All,

I have created many virtual switches to do various things (about 19 of them). Creating the 20th one and getting this message:

Any ideas whats happening? Never had a problem before although I did just rebuild my PC and its been about 6 months since I made a virtual switch.


(Bryan) #2

It MAY be related to a browser cookie. Try it with a private/incognito windows.


(Jimmy) #3

Just use the smart app in the marketplace


(Tony Fleisher) #4

“Virtual device creator” can be found in the marketplace under smartapps -> More section. It provides ui to create virtual switch or virtual dimmer switch.


(Lee Florack) #5

I’ve tried ‘Virtual Switch Creator’ but don’t understand how you individually get rid of its created virtual switches without deleting all of the switches that it has created - along with the app itself. I know that I can use IDE to delete individual switches, but they remain listed within the app.


(Tony Fleisher) #6

If you go into the things list and choose the device, there is a remove button available on the bottom of the settings page.


(Lee Florack) #7

You are correct! I knew about that option (device remove button) but I didn’t believe that using it would also remove the switch from the apps listing of virtual switches it created too. But, your message made me test it - and it does! So, thanks!


(Lewis) #8

Why would I use a third party app to do this when the functionality to create a virtual switch is right there in the out of the box SmartThings GUI?

I tried using this app before I knew it could be done as standard out of the box and it cause me a world of pain. Basically didn’t work at all.


(Lee Florack) #9

It’s not really hard to do it in the IDE but I believe that the advantages of this app are

  • it runs from your phone so you don’t need to fire up the web-based GUI.
  • It’s probably a little bit quicker
  • It keeps track of the switches and dimmers it creates

What did you have issues with?


(Lewis) #10

I managed to get the out of the box ST interface to do it by using incognito mode.

I still don’t see why anyone would use that app to do this when it takes only 30 seconds to create the virtual switch in ST interface.

I name all my vSwitches with a number on the end so I always keep track.


(Lewis) #11

Can’t remember exactly what wasn’t working. Just a whole bunch of errors. I followed the guide exactly. Many times.

All I do remember is losing a weeks worth of evenings and weekends trying to get that app to work only to find out that the app was pointless as it could be done out of the box. The time taken to read the install guide, get the bits and pieces, install them takes about as long as it would take me to create 30 vSwitches.

Wasn’t happy but at least I got vSwitches working so it meant that I could basically control any webcore routine with Alexa. My unhappiness was cancelled out by the victory but its still a bit of a soar spot.


(Jimmy) #12

It isn’t third party. This is a new app published by SmartThings that came out a couple months ago that creates them and also uses the new device type that runs locally. I haven’t tried to delete any yet, so can’t speak to the issue @lflorack is referring to.


(Lee Florack) #13

I believe that this app was written by SmartThings only abut a month or so ago because they introduced the new ‘Virtual Switch’ capability that runs locally. So, perhaps your issues were with a different app?


(Lee Florack) #14

After some testing due to a response from @TonyFleisher, I no longer have any issues with this app. You can delete the created virtual switches directly from its device entry in SmartThings.


(Alex) #15

I was having the Access Denied issue as well after being able to manually create a virtual switch from the IDE. I used Incognito mode and it worked so it must indeed be related to a cookie…