Are Virtual Switches still available?

I have used Virtual Switches for a number of automatons in the past and have created them with no problem or special code from the API. Went to add a new one today, created it identical to a VS I already have (except for the ID) and recieved the following error:

Access denied!
We’re sorry, but you are not authorized to perform the requested operation.

Anyone know why virtual switches are now denied? Or if you have created one recently what did you have to do to create it?

Thanks

I created one with no issues yesterday.

1 Like

I created one this morning with no issue. Did you put in a random z-wave ID? You need one for it to be created.

Yes, I have a specific series I use so I can be sure not to create an ID in use by something else. I’ve never seen the Access Denied before…

Sometimes you get that message when the SmartThings database is unavailable for whatever reason. They did do at least one backend change today. I would try again and if you still get the error message, contact support.

https://support.smartthings.com/hc/en-us

Tried it again, and this time it worked.

Thanks!!

1 Like