Virtual Hub?

I started on the classic app but installed the new app and when I look at my devices list I see my normal XXX_Hub, but I also see a “Virtual Hub”. I dont see this in the classic app. Where did this come from? Can it be deleted or needs to stay?


1 Like

when you click on it, what appears on the screen?

I had one of those, as well as a shed load of old devices that had been deleted for months. I assumed I’d been mucking around at some stage in the past and so treated it like the other devices and deleted it. No idea if that was good idea but others before me have reported finding and deleting it, but no one seems to have reported deleting it and discovering they shouldn’t have done.

Does not show much.

You may want to contact ST support and let them look into it and remove it for you. :slight_smile:

You can contact them directly from the app. Click on the menu (three bars in the upper left of the screen) and choosing Help.

Isn’t that virtual hub created, when you do the basic DH and SmartApp programing examples with “the_motion” virtual motion sensor?

If you’re asking me no idea. I have a custom DH for the TP-Link devices but with the new app the custom one is not needed anymore as it is native. Maybe it’s from that not sure.

After I installed my new V3 hub and moved everything over to it, I reset the V2 hub and deleted the hub and virtual hub using IDE. No longer an issue.

This is correct.

If you see a virtual hub device it is most likely due to using the Simulator in the SmartThings IDE at some point.


Yep that makes sense when I was setting up DH for TP-Link devices. Thanks.

1 Like

Now that I’ve got the new app working, I see a virtual hub, too. I absolutely used the simulater back in 2016. Just to be clear, I can just delete the virtual hub? Mine shows “offline” and I get “A network or server error occurred” when I try to look at it.

Yes, deleting the virtual hub should be fine.

I can’t seem to delete it from within the new app. I get an error just trying to view it. If I try to delete it, I get “Something went wrong. We are unable to remove your device. Please try again later.” I don’t see it anywhere in the IDE (so that I can delete it from there).

The virtual hub record deleted from the IDE but not from everywhere. I cleaned that up and you should be good.

1 Like

Thank you!

1 Like


I have the same issue on my account of having this Virtual Hub. How do I delete it?

Also directed at @Brad_ST please…

I’ve got this too and since I mostly use the classic I’ve ignored it. However, since classic is soon to go away…

My virtual hub says it’s offline and I can do nothing with it. And I only have one location. How do I get rid of it?

So this was counter-intuitive…
I tried to open the device itself and got nothing other than it spinning looking for connected devices. No menu options to delete or anything.

However, when I opened up the hamburger menu from the main page, then went to devices, there was the 3 dot menu in the upper right that gave me a delete option. I selected that, scrolled down to find the virtual hub and deleted it. Problem solved.