View Z-wave device number in app

I have a network with 52 devices, and manage the network using the Vizia RF tool and USB stick. The network operates correctly and the Smartthings hub V2 sees the devices.

Some of the devices are Z-Wave Device or Z-Wave Dimmer. For those that responded, I renamed them to match their function (eg. Kitchen Lights). However, there are about a dozen devices that I can’t figure out what they operate.(yeah, I have various outside lights, hallways, etc).

Is there any way to view the Z-wave device number in the app? Or somehow through some other software that talks to the hub? I can then cross-reference to Vizia (which has all names) and input the correct name.

You can see your account details, including the device IDs, in the “IDE.”

In order to get there, just go to the first page of this forum and then click on the “developer tools” link at the top right of the page. That will take you to sign in for the IDE.

Once you get there, click on the tab that says “my devices” and you’ll see a list of all your devices with information about them.

I think the device IDs are in hex, but to be honest I don’t remember. Just verify that either way.

Thanks. But hmm… even though I signed in with the same login name and password my hub and devices are blank. Instructions say to use the app, which of course is already active and running.

Any hints?

After you log in select My Locations then select Home.

A+ for both answers. Thank you for that. I was able to use the codes to name the devices. Now I just need to figure out why roughly 6 devices on the network are missing in Smartthings. Vizia is able to see and control them.

I tried to add the device manually (it’s a generic Z-wave dimmer) with the proper code in hex and get

Oh No! Something Went Wrong!
500: Internal Server Error
Reference Id
Sat Dec 09 16:12:41 UTC 2017

What is the url (shard) that you are on when you log into IDE? (ie:,, etc)

Just for kicks. Do me a favor and logout of ide and then goto and login from there.

They have been doing some screwy things lately and just want to make sure that you are being redirected to your correct shard ok. If you do that and it redirects you to na02-useast1 again, then you are good and you can disregard.

Put me back on the same shard:

Funny that it’s an east coast shard even though I’m in CA.

1 Like

I’m in the west as well and that’s my shard too. I know they have multiple shards on the east, up to na04 now I think.

Well that’s not your issue. :slightly_smiling_face:

Tried to another, different, device. Similar error.

Oh No! Something Went Wrong!
500: Internal Server Error
Reference Id
Sat Dec 09 16:45:44 UTC 2017

Other actions (edit, delete) work OK.

You are getting that in IDE when trying to save it?

Share a screenshot of your values before saving

Yup. I assume the Reference ID means something to someone.


Remove the Hub value

1 Like

Already tried that: “A Device must have either a Location or a Hub”

Funny that it’s not starred as required when it is required.

Aha! Location works, with the possible value ‘home’. Hub fails.

Seems the device isn’t local, it’s in the cloud. Hmm…

Meantime, the added device shows up on my phone, but doesn’t work (no on/off action). Initial state on the phone is ON, when the lights are actually off. Attempt to turn off, the app stays with ‘turning off’ as the state. Changing dim level has no affect.

OK, this is a good start. Let me add all of the missing devices, delete the ones that don’t exist, and do a full repair of the network. There might be some subtle bad states somewhere that messes up smartthings.

Thanks for all of the quick replies.


I only populate location if I am creating a manual device.

Once you have them displaying in the app, it comes down to the network id being correct to actually give function to the device.

Agreed. 36 decimal directly from Vizia, 24 hex. Smartthings says the device is online, so it’s seeing something. I’ll post an update after the full repair.

Thanks again for the quick responses.


1 Like

Other thing you can do. Press the On or Off button in app and then in IDE goto Location / Events and see what it shows for that switch…

And if you click on the date for that event it will open it up.

Good tip. I already tried that. Saw no events logged. I have a hunch that Smartthings says it’s a cloud device, which means it’s internet connected somehow vs. local as all of my other devices are.

Still working on network cleanup and repair.