V3 hub is offline with solid blue light

Hey, I’m experiencing the same… I went on vacation for a month, and for that reason I paused my internet subscription as I didn’t want to pay for wifi while I’m gone. When I got back yesterday I opened my subscription again, all devices started working immediately… except… smartthing hub. First I tried rebooting it, then rebooting my router, then removing my switch and connecting the hub directly to the router. No cigar. when it boots up it first lights red for a few seconds, then start blinking blue and quickly turn to solid blue.

I’m literally going to return it if there is no other way of getting it back online without losing all my configuration, that is just completely unacceptable.

Please ping me if anyone finds a solution to this.

1 Like

I wonder if a soft reset will have any impact…

soft factory reset by following these directions:

  1. Disconnect the power cable from the Hub
  2. Using a pin or a small tool, hold down the reset button on the back of the Hub
  3. While continuing to hold down the reset button, replace the power cable
  4. When the LED on the front starts flashing yellow, release the button

You may want to contact ST support before attempting anything and see what they say.

1 Like

Thanks, I just sent them a support request. Hopefully the more tickets they get on same problem, they will start taking it seriously. (if these issues happen to be related)…

I will share everything they reply right here and my experiments and results.

For now… I will eat my dinner in the dark

I do have a spare ST hub and i try to reprocedure this problem. I have already started with this experiment in order to replicate same scenario with brand new installed ST. I will keep you guys posted.

Thanks a lot for that effort. I kinda almost hope that you will be able to reproduce the issue, and that this is a consistent issue that they will have to deal with. If the hub needs complete factory reset after every internet or power outage it is basically useless…

Also I was shockingly disappointed to find out that my alarms didn’t go off when my door was opened while the internet was gone. I totally expected features such as security alarm systems to be able to execute without internet, just locally. This makes it extremely easy to disable peoples alarm by jamming or deauthing wifi. :confused:

It’s now 4 full days since my support ticket and I haven’t heard anything from (samsung? or smartthings?.. it’s not super clear to me if this is the same company or not)

Unfortunately smartthing support is useless regarding this issue. I dont believe you will get an answer from a potent service giver in reasonable time. My only solution was factory reset.

Well if that is the case I will take it to RMA and have it returned. Oh boy I have been through this with a lot of companies…

Can I ask you something? After the factory reset did you have to re-create all your automations etc? Or did they working after you manually paired all of your devices again? I also wonder why it is necessary to repair the devices, if everything is stored in the cloud anyway… that would include the address/ids of the devices and should be easy to pull, and automatically reconnect? Seems a bit odd to me :thinking:

Have you tried the soft factory reset I mentioned above? The soft factory reset does not remove your devices or any automations you have set up.

Nope. Giving it a go now :wink: thought you recommended me to wait until support got back, but my patience is running low anyway so let’s see what happens.

Might be wise to see what they say first. I forget if these instructions are for the v2 hub or v3. Maybe one of the ST staff members can offer you some assistance. Tagging @Brad_ST

1 Like

Well well, seems like it just applied an firmware update after the reset aaaaand actually went online again. :slight_smile:

After the yellow blinking and I released the reset button it went on solid purple followed by blinking pink followed by blinking blue, followed by solid blue and finally went to green. Not sure if that order of light indications makes any sense (downloading firmware before getting online?? lol), but that is what happened.

i also had to hard reset and re-learn everything by resetting each IoT device 1 by 1. It was also important to remove the hub from cloud

So it is working for you now?

Yes. Seems like it, just checking all my devices, switches and lights seems to work. Temperature sensors seems odd though, displaying very low temperatures while i feel quite warm, but they are reporting online at the least. Thanks for the tip man! glad I didn’t wait any longer for that support and just tried.

@taskin I feel your pain bro :sweat_smile:

2 Likes

After factory reset you have to start from scratch…

Just wanted to give a huge thanks for these instructions. My v2 hub randomly stopped working (solid blue light) despite no issues with my internet service. Numerous attempts to remove the power (including batteries) failed but this resolved the issues WITHOUT HAVING TO RE-ADD ALL DEVICES! Note that I had to remove the batteries first, but then pushing the button and re-attaching the power caused the hub to apply a firmware update (maybe this was what caused the issue?) and, after a couple of minutes, the LED went green with everything as it was before. I am so grateful that I don’t have to waste days of my life trying to set everything up again!

1 Like

Were you able to get your v2 hub back online? Mine is doing the same thing. I have tried the factory reset. It will not get past the solid blue light.

Did you perform hard reset? Or soft reset where it only prompts the hub to connect to ST servers and download firmware? The hard reset would be a drastic step that is not a guarantee to resolve this issue.

A better method would be to power down your hub for several minutes. Remove the battery if it is a v2. And be patient, some report it may take a day or so before it reconnects. Also, try plugging directly into your router and change the dns settings to a public dns server temporarily.

It is frustrating - just be aware this issue requires patience. :frowning:

Also, contact ST support and report your issue.

See more in the following thread…,

Thank you. I have performed the hard reset. It is still showing blue. I will give it a day or so.

I took several resets and a few router reboots, but this finally worked. My hub is back online.