Utilitech siren

Hey guys. Just wondering if anyone else has had a problem like this. My siren will not sound when needed but my aeon labs siren upstairs does. I re-added, pulled batteries and made sure it was loaded with the correct device type. This is what it looks like in the ST app. The off button is there but the on button isn’t. Any help would be greatly appreciated

Which device type are you using? I created a device type for this siren that’s using the new tile format (won’t run locally yet), and it’s working. Here’s what it looks like if you want to use it:

Let me know which device type you’re using and maybe I can help. It could just be that it didn’t pair correctly (that’s my guess).

You are right. Last night I just kept trying to pair it over and over and it finally took. That device type looks great! I might try it anyway. Thanks so much for the feedback!

@drake0508, cool, glad you got it working. If you want to try what I’m using, here’s a link to the code:


1 Like

Awesome! I’ll load it up now. I wish I understood the code like you guys do!

This is a huge improvement!

1 Like

What app would you suggest for triggering this siren based on windows and doors being opened after a certain time of night. It would also be nice to limit the length of time the siren is going off.
How do you turn off the siren if it does not have a time limit?? From your phone ?

Any feedback on how others are silencing this alarm ?

I was using my phone to silence it but I haven’t had any false alarms in a while. I have a button set on my aeon remote in case my fiance needs to shut it off or on. I’m sure (correct me if I’m wrong everyone) that you could use the security remote to toggle the siren on and off. It would be attached to your keys and you wouldn’t have to pull your phone out.

I will check into the Aeon remote or some sort of smart button to turn off alarm.

Thank You.

You can turn the siren off as part of a routine. When I have a false alarm I just run “I’m back” and it silences the siren.

@johnconstantelo do you still have this code? the link doesn’t work anymore.

I have the same problem as @drake0508, his screen shot is identical to what i have only off no way to turn on the alarm.

Thanks, -EB

Sure do:


It looks just a little different but functions the same. I moved the code a while ago, and forgot to update this discussion with the new link.

Thanks @johnconstantelo,

This only kind of fixed my issue. I can now turn the siren on and off according to the app, but the siren never actually responds.

Once I change the device type and open my smart things app, the siren shows as “alarm!”, however its not going off.

I can go into the siren and “turn if off” however when i go back to the main things menu it still displays as alarm, but again no sound is coming out of it.

any thoughts or ideas?

I’m attaching some screenshots from the IDE.

I have read in other community post that the device status of “inactive” doesn’t matter, but it does seem weird to me that the only device listed as inactive is the only device not functioning properly.


Something isn’t set up properly when the device was included. I highly recommend excluding it and re-including it (via the phone app). When it gets reincluded go back to the IDE and change the device Type* to your custom device handler.

In the second image you provided, it shows “no states found” for Current State. That tells me the device was not included to your hub correctly. It should look like this:

thanks. I tried about 5-6 times this morning of excluding and reincluding it, but have yet to get it to properly pair.

@drake0508 - about how many times did you have to exclude/reinclude yours before you got it working correctly?

was it 2-3 or more like 10? just don’t want to keep wasting my time if its not worth it. Considering returning this and just buying the aeon labs siren, but i did like the fact that this one didnt need to be plugged in.

Thanks, for all the help so far John.

No worries Erik. I had to pair the siren right next to the hub. Literally only took 1 or 2 tries.

For some reason I’ve been having problems including devices lately (um, since the last firmware update I think…), and I had to reboot my hub to get a device to join this evening. You may want to reboot as well and try again.

I just paired this utilitech siren yesterday. I have the same UI as your post. I haven’t really tested too much since I have some questions I need to talk first with the Smartthings support team.

Anyway, you mentioned there was no On button. I think it stays off. It only turns on when it alerts. The on button actually is the off siren icon I guess since I hit it that triggers the siren.