Using Routines to Trigger Smart Home Monitor State Change


#1

I see multiple threads indicating that a Routine can be used to trigger a state change in the Smart Home Monitor, ie. Good Bye! triggering Away mode which then triggers Arm Away in the Smart Home Monitor, but I don’t see any place that tells me how to do that. So, how do I setup the Good Bye! routine to trigger Away mode (this part I have done), to then trigger Arm Away in the Smart Home Monitor?


CoRE and Piston Rules Engine, first design steps
(Tracy) #2

Under settings for the routine, you should see “Set Smart Home Monitor to”, where you can set the appropriate setting.


#3

I don’t see that option. My view goes directly from Set Dimmers to this level to Lock these doors. No option for Set Smart Home Monitor to.


(Tracy) #4

That’s weird; do you have SHM configured with something (anything) to do? I wonder if it doesn’t show up as an option if there isn’t anything for it to do.


(Robert Robinson) #5

You have to shutdown the app then restart…It shows up then


#6

Shut down the app, shut down the phone. Restarted both. Still same result. To answer @Carinda, I have configured the Smart Home Monitor for Security and for my Water sensor.


(Robert Robinson) #7

It worked for me, it was not there when i first setup the security portion of shm. i forced stopped the app and restarted, i showed then. try shutting down app, rebooting the hub in the ide…restart app…


(Tracy) #8

That probably explains why I didn’t see it the first time I looked and found it later. I thought I had lost my mind and missed it somehow.

@u00abe1, I’d probably try support since you tried that already.


#9

Yep, headed to support. Rebooted my hub, phone and app. Still same.


(Robert Robinson) #10

It may take it a while to show up, like @Carinda i looked and it was not there, looked again later and it was…


#11

How much later? I’ve now also tried reinstalling the app. That too resulted in same. I’ve also tried several times to uninstall the Smart Home Monitor, wanting to just reinstall it again, thinking that could be the issue. Oddly enough, I get an “unexpected error” message every time I try to uninstall.


(Tracy) #12

I’m not exactly sure when it showed up for me; I had family in town so there was a few days between setting up SHM and adding it to a routine. I just left it unarmed during that time and then played with it after they left.


#13

@Carinda and @Robert_Robinson, thanks for the help. I’ll give it a try again in the morning. If still not working, will head to support.


(Tracy) #14

Good luck!

(20 chars)


(Ron S) #15

Shoot an email to support. They should be able to enable/push it to you…@u00abe1


#16

Support was able to uninstall the Smart Home Monitor, something I couldn’t do, and reinstall it. Once they did that, everything worked. My routines now set the mode and the mode sets the home monitor, just as it should. Solved.


(Scott) #17

What is email address to support? I just spent 6 hours ripping down a Hub 1, booting up a Hub 2, adding everything back to the system - now trying to setup routines and automations, and despite being able to set the mode in SHM when I had Hub 1 running, I can’t find it the routines when setting up Hub 2!! AWESOME!!


#18

support@smartthings.com


(Scott) #19

Thanks - I hit the online chat. Found a quick and easy fix for the problem.

Go to Smart Home Monitor - arm the system to ARM (Stay), the DISARM. That will put the option back in the ROUTINE settings.


(Johnny) #20

This resolved my issue. Strange and easy fix :wink: