Using aqara hub as a matter bridge into smartthings? (Sept 2023)

I’ve got an Aqara hub (E1 stick) that I’ve connected using Matter since receiving the recently released firmware update for my Aeotec hub. I’ve got a few Aqara temp/humidity sensors that were properly added when I connected the Aqara hub, but they’re not reporting either the temp/humidity. I’ve got these same sensors added to the Apple Home app in iOS and it’s correctly reporting there as well as in the Aqara app.

Here’s what it looks like in the Smart Things app.

Thanks for your help, I’ve already contacted SmartThings support, submitted a ticket and given access to my account to SmartThings so we can try and figure this out. I know there are quite a few people with these sensors that would love to be able to properly connect them.

Tagging @Automated_House

I’m also just going to add, that the process for adding the Aqara hub is interesting. I’m not sure if its related to this issue. If you add it from the Add Device >> (Partner Devices) Add >> Matter and then use your pairing code, it pairs fine.

But, if you try and add when SmartThings prompts you (the automatic prompt that detects the Aqara Hub), OR if you try and pair via the Scan for nearby devices, I get stuck on this screen below after hitting the OK button. The language here is kind of odd as well…“webpage will be open” :face_with_monocle:

My M2 bridged Aqara devices showed up in Smartthings sometime during the night. They all have generic names that need to be changed but they are all there. One thing I noticed is the motion sensors don’t have the illumination value anywhere and the temperature sensors don’t have the humidity anywhere.


My temp and humidity sensors are also not reporting values.

Thanks Jimmy, which Aqara hub do you have?

I just add my camera hub g3 and have the same issue with the temperature and humidity sensor
The battery report well and the door sensor works fine…

I have the camera hub g3. door/window, motion, and switches work fine via the Aqara bridge. Only the climate sensor has an issue. Interestingly, the Switchbot temp and humidity sensors in their hub 2 show up as two separate devices via Matter. So I wonder if it has something to do with them being combined for Aqara?

1 Like

Interesting…yah, they are separated in the Apple Home app for me as well.

Has anyone got this working with Aqara Blind motors? Do they come across?


All my blinds appeared overnight recently and I was stoked. But as I am going through and renaming them it seems that the status of some of the blinds are incorrect ie they show open when closed and vice versa. And the control of the blinds in ST is really laggy. Had anyone else got any experience with these…its like i need to reverse the status somehow

1 Like

Just received a pretty disappointing reply from SmartThings support. I already spent time on the phone with them plus did these exact things already (submitted logs). Not to mention, they’re saying I am experiencing a cloud connection delay, which is incorrect. This is obviously an issue with how these devices are being brought into SmartThings via the Matter bridge. To any SmartThings employee/developer/tech support person reading this, I am willing to help diagnose this issue, but this needs to be escalated to dev and given non-generic responses.

My Aqara devices are still not reporting temperature (but they are reporting a battery percentage that is the same as the percentage listed in the Apple home app).

Update on my end: I contacted SmartThings support to check on the issue. They are either stalling/running interference for dev, or these guys have no idea what they are doing. They’ve now asked me no less than 4 times to send them my app logs for this. I’d rather be talking to an AI support bot.

I’m nearing the end of my patience with SmartThings. I’ve been with them since Kickstarter (2012). I’ve got 90 devices connected. Is there anyone from SmartThings that’s willing to provide some insight on this issue here?

Not likely here. This forum was set up many years ago so that customers could help other customers it’s not officially monitored by smartthings staff except for the usual moderator stuff like spam and harassment.

there is a communications pipeline for “Developers,” but that’s only a couple of employees, and isn’t likely to apply to the issue you’ve run into.

When a customer contacts regular support, the first people you get are just Samsung support center people working off a script. They don’t typically know anything about smartthings and get a lot of stuff wrong. But if you hang in there and keep poking them, eventually, it usually does get escalated to an engineer, but it could be a really frustrating process.

But I think the short answer for now is that the whole matter integration is still very new and incomplete.

You can try reporting it to aqara support and see what they have to say.

Or you can make a comment on one of the public facing platforms like Facebook or Twitter Dash X and at least that way you know some Samsung employee is going to see it, although it still might not get to an engineer.

BTW, the sensor values not being reported for a matter bridge are a known issue with smartthings and apply to multiple brands, not just aqara. It’s been noted on industry blogs for several weeks. That doesn’t mean there’s a fix available, but it does mean that Samsung engineering should already be aware of it.

1 Like

Thanks JD. At least I’m not alone :sob: :sob:. I’ll keep nudging until I get a decent response.

1 Like

Hi @Mark_Harrell, thanks for your patience, we definitely want to see this device working as well and I’ve escalated the issue to the team working on bridge and matter functionality. I’ll send you a separate DM to get the information about the support ticket and required info for the engineering team to grab the logs and take a look.


To update the thread, we have worked with @Mark_Harrell to gather information and have reproduced the issue. We believe we will have a resolution to support this device properly as part of the upcoming 0.50 release and will work with Mark and others to confirm the fix during the beta window. Similar issues may be seen by some other “Composite” bridged matter devices and we welcome reports on other specific bridged devices that are exhibiting similar issues.


Thanks @posborne, look forward to helping in any way I can.

Tagging @Automated_House , who I believe has seen a similar issue on the SwitchBot Hub 2.