Aqara Temp/Humidity sensor - Matter - seen as light

So I have some Aqara switches added directly to ST and they work fine because with the edge drivers they support decoupled mode automations in ST.

I also have bunch of devices added to ST through Aqara’s hub so they’re basically Matter Over Bridge. And they work perfeclty fine (Plugs, the T1 led strip etc).

However - the temperature and humidity sensor I need in the Aqara app and I also need in Smartthings. It goes to smartthings as a Matter device, but it’s recognized as Light and for some reason (maybe known reason) I can’t change the driver of a matter connected device to the Aqara’s temp sensor edge driver.

Is there any solution to that?

Does the device show up in the Advanced Web App as a Matter device? If so, what driver is assigned to it?

You likely can’t change the device’s driver because its fingerprint doesn’t match any of the stock drivers. That would make sense as it’s not identified as a Zigbee device since it comes in via Matter over Bridge.

Just as a side note- google home recognizes it fine with all readings etc perfectly.

It is in the Advanced Web App, yes, as a matter device from Aqara.
The profile is “light-level-colorTemperature-2710k-6500k”.

The aqara temperature sensor driver is only for devices using zigbee to communicate directly via Zigbee with a Smartthings Hub. That’s why you can’t change something brought in via Matter over bridge: the individual devices aren’t directly connected. It’s their bridge which is handling communications.

So this sounds like a problem with the matter bridge integration to smartthings: you should report it to aqara support. Let us know what they say.

Guessing it’s using the matter-switch driver if that profile has been selected. Looking in all the stock Matter drivers, there appears to only be Matter Bridge support in the matter-switch driver. The only devices in the fingerprints.yml that match that profile are the:

  - id: "Aqara LED Light Bulb T1"
    deviceLabel: Aqara LED Light Bulb T1
    vendorId: 0x115F
    productLabel: Aqara LED Light Bulb T1
    deviceProfileName: light-level-colorTemperature-2710k-6500k
  - id: "Yeelight Smart Lamp"
    deviceLabel: Yeelight Smart Lamp
    vendorId: 0x1312
    productId: 0x01
    deviceProfileName: light-level-colorTemperature-2710k-6500k

So, I’m with @JDRoberts that there is something weird going on with the bridge integration. I’m not sure if it’s an Aqara issue or the fact that there only appears to be Matter bridge support in the matter-switch driver. I’d say contact support, but I’d be surprised if they could track it down with escalating to engineering. @nayelyz @AlejandroPadilla can you comment?

I’d also be curious to know what deviceTypeId the device is identified as and what the Vendor ID is. Check the API Browser+ by clicking on Devices->“Your Device”->Details and scrolling to the bottom of the details.

1 Like

Hi, @maximilian_b
I asked the engineering team about this case, and they mentioned this was a known issue with the fingerprinting logic for Aqara bridged devices but it’s solved now. So, re-joining the devices should solve the issue.
Please, let us know if you have further problems with the integration.


Yeah, I thought it was the Aqara Light Bulb that might be causing the issue because it had only the vendor ID and no product ID. The comments in the commit confirm any Aqara device (other than the bridge) was being assigned that profile since they all would match on the vendor ID. Now, with no Aqara specific device fingerprints (except for the bridge), I presume other Aqara devices will be assigned a profile from the generic section based on deviceType.

Works now :slight_smile: