Upgrade Nest Manager from 4.4.2 to 5.5.2


I set up my Nest Manager over a year ago and landed on version 4.4.2. I know I’m a ways behind, as I now see in the app that the latest version is 5.5.2. I am trying to upgrade through the IDE, but I can’t seem to make it happen. I have connected to GitHub, and when I tried “Update From Repo”, I was able to install the “NST Automations” app, but I can’t seem to get the “Nest Manager” app to update. I did something and it turned from green to purple in the IDE, but I can’t tell what that means or how to undo it. Any advice?


Indicates that the file is unchanged between your forked GitHub repository and the IDE.
Indicates that the file is in the IDE only, and not in any repository.
Indicates that the file exists in your GitHub repository, and has been modified in the IDE but not committed to the repository.
Indicates that the file has been updated in the repository, but not in the IDE. To resolve this, you should click the Update from Repo button, where you sill see the file appear in the Obsolete column. More information about the Update from Repo button can be found below.
Both the IDE version and repository version have been updated, and are in need of a conflict resolution. To resolve this, you should click the Update from Repo button and follow the steps there (more information about the Update from Repo action can be found below).
Indicates that the SmartApp or Device Handler is unattached to the repository version. Typically this happens when a new SmartApp or Device Handler is created from a template, and the name or namespace hasn’t been changed. If you update from the repo without changing the name or namespace, the IDE version will be replaced with the repo version. Typically in this case you would change the name and namespace to be unique for your code.


can you take a screenshot of your NST smartapps in IDE and post. Also, did you update the device handlers?

Hi jkp,

Thanks for your quick response. Please find my screenshot

. I believe I updated the device handlers, but I may have done so out of order.


I can’t see your posted image. You may also want to posr your question in the NST manager thread. that way, the developers will be sure to see your question and respond to it

Sorry for the missing image, I just edited the post to make sure the image is correctly uploaded. I will post there as well. Thanks again!

FYI - Half of the DTH’s I recently downloaded (new location / reset location) were magenta, mostly because of a blank line at the end. So if they were freshly downloaded I wouldn’t worry too much.

Thanks Allan for the suggestion. I won’t mind what the color is if I could get it to update!

run Update from Repo again, select the NST Manager and click on Publish at the bottom and then click Execute Update.

I’ve done that a few times jkp, but no change on the color OR the status of the version in the mobile app.

click the magnifying Glass towards the left of the name, then choose Overwrite Local version in the upper right, then save at the bottom. Next you will need to click on the name and publish the app again.

once you update, possible it will want a nest developer account.

Interestingly, it did update now, turning back to the normal black, but now the “Status” column says “Edited” and the magnifying glass button moved over there. What does that mean?

1 Like

you need to click on the name and publish it again


Woah, that worked! Thanks jkp. I hope I remember this all for next time! :wink:



Just wanted to say thanks. I was having the same issue. You solved it for me.