Updated UI for Nest


(Patrick Stuart [@pstuart]) #1

Code:

Screen shot:

I updated the UI / UX for the Nest App to remove that horrible slider on android and add up and down temp buttons.

I also signed up for a github account, never had one before, I’m old school cvs/svn guy.

Apologies for potentially not following proper protocol for forking or attributing credit to the original owner…


Help setting up Nest Thermostat
(Brian Smith) #2

Two questions

  • does it work when the Nest is set to both heat and cool with the range
  • can it set the Nest to auto away rather than away? This is important for allowing the schedule to work and pre-cool/heat.

(Marc) #3

Is this using the new API Nest released or an update to the original code out there?


(Patrick Stuart [@pstuart]) #4

If the old code didn’t then no.

However I don’t see why it wouldn’t be too hard to do.

This is not using any official nest api.

As for away vs auto away. These are apples and oranges.

Away is a state. A Boolean. Either you are away or you are not.

Autoaway is a setting in nest sense that allows the nest sensor to determine if you are home or away and sets the state automatically.

Why do you want to change the auto away setting?


(Marc) #5

Thanks. I updated my code, but I have iOS. Should I be noticing anything different because I still see the slider bar? I didn’t recreate my devices, rather just republished the device type code.


(Patrick Stuart [@pstuart]) #6

If u see the slider then you didn’t publish your changes. Check your device settings as well


(Marc) #7

Hmm…I replaced the code that was there and saved and hit Publish for Me for the Device Type. Anything else I should be doing? Will this work for iOS?


(Matt) #8

you need to exit the app not just close it


(Patrick Stuart [@pstuart]) #9

Try force quiting the app on iOS and relaunch? Might cache the app


(Marc) #10

Haha, I am one step ahead of you and that didn’t work either. I’ve never re-published a device type before, only a smartapp. Maybe with device types, you need to create devices over again? I hope not because that is a royal PIA.


(Marc) #11

Got it! Logging OUT and IN fixed it. Just an FYI if anyone needs to do so. This looks great, nice job!!!

I just wonder how much improvement we will see with the Nest API now officially out.


(Patrick Stuart [@pstuart]) #12

@brianlees I made some significant changes to the code to allow for the range mode to work along with the other modes.

Take a look at the github and let me know what you think.

I also improved the accuracy of the temp coming back, it was truncating the temp instead of rounding. Should be a bit more accurate to what nest app shows.

Screenshot here… https://plus.google.com/109218861040495449466/posts/VJXAosTYZGP

Code here… https://gist.github.com/pstuart/17cdc5bf36d434baa6ab


(fightingmajor) #13

I have tried many different times to get my Nest added into SmartThings and I was not successful. After trying it again with the code here it worked perfectly. Thanks.


(A2thejay23) #14

it doesn’t update unless I manually click on the refresh tile…do all the versions of the Nest code do that?


(Patrick Stuart [@pstuart]) #15

You just need a smart app to subscribe to the nest presence event and use something, ie a motion sensor to set it back from away.


(A2thejay23) #16

whats the subscribe function code (For subscribing to nest present even specifically) look like so i can see if any of apps im planning on use with nest have it?


(Patrick Stuart [@pstuart]) #17

@a2thejay23,

Check out this code https://github.com/pstuart/smartthings/blob/master/set%20tstat%20to%20not%20away.groovy

It sets the away mode of the Nest back to home after the Nest has either Auto-away set to Away or you manually set it in the Nest device.


(Brian Smith) #18

@pstuart - The updated UI is very nice. I like it. I loaded the Thermo reset on motion app, which we’ll be able to check out on Friday when my wife is home and not in the regular locations (or I’ll just cover the thermos up).

How do you get the Nest to go into Away mode as soon as the ST mode changes to Away? I know we have gone back and forth on auto-away (and I’m still looking for that long term :)), but I’m curious to see how you tell Nest that no one is present on the mode change.


(Patrick Stuart [@pstuart]) #19

Ok, hard to explain how to get to it in the app, but its already built in…

Go to dashboard, click the “Quote bubble” in the upper right corner.

Click the gear in bottom right corner

Choose a mode you want to use to set thermostat to away, ex Goodbye!

Scroll down to Set the Thermostat, choose your nest

set the other options to your liking

Change the mode to, set to away (default)

Set conditions to automatically put in goodbye to your choosing.

Should set Nest to away when mode = goodbye

FYI, I don’t use this, so haven’t tested it, but should work fine.

Also, did you check out the update to the away smartapp, I added a daily away and not away schedule event. So you can remove the nest from away at 4pm M-F if you want and set it to away at 8am M-F and then if any motion is detected in the house during that away time, it will take it out of away.


(Brian Smith) #20

Do I have to set the temp in the mode? I saw the settings, but I didn’t want to choose temps since I have that all setup on both Nests.