Can I set Nest to "away" with my "Goodbye!" routine?

smartapp
routines
nest

(Jeff Robbins) #1

First off, I’ve been using @tonesto7’s AMAZING Nest integration Smartapp/Devices. It’s a really beautiful SmartApp – better UI than most (if not all) of Smartthings’ own!

However, I’m trying to figure out something that I would think would be pretty easy:

When I leave the house, I’d like to my Nests to “away”. And when I arrive home, I’d like to set them to “home”.

However, I can’t seem to figure out how to do this with a (Hello Home) routine. I’ve also tried to do this with Rule Machine, and while it gives me the options for “auto”, “heat”, “cool”, “off”, and “emergency heat”, none of these seem to be quite the same as “away”. Am I missing something?

I notice that I can set the Nest Presence device to “Away”. Does this set all of my thermostats to Away? Is there a way to control this function through a SmartApp? If this were set up as a switch, I could turn it on and off with just about any SmartApp. But again, I feel like I’m missing something.

Thanks in advance for any help or pointers anyone can give!


(Anthony S.) #2

Use the nest automations inside the manager app. It has exactly what you’re looking for


(Jeff Robbins) #3

Thanks Anthony! In iOS, when I click on Create New Automation, I get the spinning wheel and then nothing happens. I’ve got the latest version from Github. Any ideas how I might fix that?


(Anthony S.) #4

make sure it’s published and watch the IDE Logs while you try to open it on the mobile app


(Jeff Robbins) #5

Hmm… The SmartApp is definitely published. So are the 3 device handlers.

When I open Live Logging in the IDE and click on “Create New Automation…” in the app, nothing new seems to show up in the log.


(Jeff Robbins) #6

There’s also a setting in the Device Preferences to set the Nest mode to Auto when Smartthings location is Away. Will this do what I want to do? Is the “Auto” mode the same as Nest’s “Away”? I assumed that “Auto” was the mode where heat and cooling were both active and Nest would automatically switch depending on whichever was needed. Why would you want to set to this mode when Smartthings is “Away”?


(Jeff Robbins) #7

I removed the Nest Manager SmartApp and reinstalled it. Then I went in and turned on all of the App Logs in the Preferences section. However, still nothing is happening when clicking “Create New Automation…” and I’m also getting nothing in the IDE logs.

Hope this is helpful.


(Anthony S.) #8

Something is not installed correctly> Without an error of some sort it’s near impossible to troubleshoot

I’m working on some updates right now that I will release tonight. Maybe that will help.


(Jeff Robbins) #9

Thanks Anthony! You’re the best!

I’ll keep messing with it on my end and see if I can figure anything out.


(Fred Schmitthammer) #10

There are two smartapps. One for automations and the manager. Make sure you install both in your graph ui.


(Jeff Robbins) #11

That was exactly my problem! I had been using the GitHub integration to update the app in the IDE and I missed it when @tonesto7 added the automation app. I’ve got it and now things are working great.

I can’t overstate how awesome this app is! I was about to switch over to Ecobee so that I could have multiple sensors and better Smartthings integration. Now I can use my Smartthings motion sensors as external heat sensors and automate all sorts of things.

You kick ass, @tonesto7!


(Community Journeyman) #12

I’m have the same problem. @tonesto7 do I have the latest SmartApps?

  • Nest Automation - V1.0.1 (Apr 22nd, 2016)
  • Nest Manager - V2.0.2 (Apr 24nd, 2016)


(Anthony S.) #13

Sorry I missed this message hold off until tonight or tomorrow I have a pretty large update coming very soon that should iron out all of these issues