[UPDATED] Rule Machine with Triggers


(Bruce) #1

Rule Machine

Rule Machine with Triggers is now part of the main Rule Machine. Please refer to the main Rule Machine topic for documentation and instructions:


Best logic to automate bedroom lights
How I got ST working reliably for me
Hub V2 + Cree connected bulb + Smart lighting app?
Garage Door + Motion Sensor
Need HVAC Control
Rule machine - as per the app developer, this app is no longer available for new installs, distribution, or support
Blind motor has auto cut off, is there an app that can track its position?
[DEPRECATED] Trigger Happy!
Change modes by location?
Rule machine - as per the app developer, this app is no longer available for new installs, distribution, or support
Rule machine - as per the app developer, this app is no longer available for new installs, distribution, or support
(Never Trust @bamarayne) #2

With this new release, when I create a new rule or trigr… and then go to remove it, I am getting:

deleteObserver onError: %s

On Android


(Bruce) #3

That’s interesting. I will look into it. This “remove” functionality is new.


(Bruce) #4

Looks like the Android version doesn’t work, or maybe my Android device doesn’t work.


(Bruce) #5

I just pushed a minor change, if you could re-download Rule and Trigr.


(Jason "The Enabler" as deemed so by @Smart) #7

When I make a new rule and click on action for true i “You are not authorized to perform this” error and when I try to remove the unfinished rule, I get "deletObserver onError:%s.

I’m on androis 5.1.1 Samsung Note 4


(Bruce) #8

I’m not seeing this on my Android device. Did you update Rule Machine, Rule and Trigr?


(Jason "The Enabler" as deemed so by @Smart) #9

Yes, I updated from repository via the IDE


(Bob) #10

Great job on this, Bruce… and great job on the documentation too (a rare combination)!!


(Andreas A.) #11

Awesome job - very impressed!

One thing that is missing in order for me to be able to replace my custom “fake presence” app: would it be possible to add a “random delay - max xxx minutes”? That allows to simulate occupancy without being too obvious since the timing is different every time.

Fully understand if this is too specialized (or too confusing for the interface or most people) but I thought I’d ask…


(Bruce) #12

Interesting idea. I shall think about it.


(Nick Snyder) #13

@bravenel

So I have updated the Rule Machine, rule and added Trigr. When I open the app for the first time, I have blank rules at the top of the list as well. Attached a photo.


(Bruce) #14

Those are from previous failed attempts to enter a rule. If you can open one in the mobile app, just remove it from inside it. If you can’t open them, you can remove them from the IDE. My Locations / List SmartApps / Edit (top right), then you can find them under Rule Machine and uninstall them. They are harmless, just clutter.

You are using an older version of Rule Machine. You might want to update!


(Nick Snyder) #15

Yea, I updated after posting that picture. I now have your super app.

I have gone into the IDE and its not letting me delete the failed rules and triggers. Just says ‘There was an error uninstalling your SmartApp.’


(Nick Snyder) #16

I even tried filing in all the info and try remove it after that and still get an error. Maybe I need to remove everything and start fresh?


(Bruce) #17

If you don’t have a lot of rules, then yes, that would be the best way to go.


(Bruce) #18

Be sure to hit Done on Rule Machine at some point after you install it in the mobile app. Then it will be shown under the SmartApps tab (may have to hard restart the mobile app for it to show up).


(Nick Snyder) #19

So I cannot remove any rules from the app. Everytime I do, it says an unexpected error occurred.

I am more than happy to start over but the system will not let me uninstall anything.

Getting this error in the live log.

2:44:37 PM: error java.lang.NullPointerException: Cannot invoke method remove() on null object @ line 118


(Nick Snyder) #20

@bravenel Also, when I create a new rule, I get the green message at the top that says its create and the automation is running but it stays on the window where you program everything. When I hit done, it says Failed to ave page:selectRule.

And in the live log I get this:
2:48:30 PM: error java.lang.IllegalArgumentException: Maps with null keys can’t be converted to JSON


(Bruce) #21

Can you uninstall Rule Machine in the IDE? The Rules should disappear if you do that.