Unsupported devices and "generic" profiles for them


(Brian Smith) #1

Am I correct in saying that although a zwave motion sensor (for this example) may not be directly supported for the exact model, all zwave motion sensors (or any other generic type of sensor like a door sensor, etc) have the same core functionality that could be displayed in a “generic device profile” for that device type?

When I added my monoprice motion sensor, it came up as an Aeon sensor with blank tiles under Things. What about the possibility of the following:

  • User presses the + to add the device

  • ST recognizes the device, but can’t find a device profile for it

  • ST prompts the user

    This device is not officially supported by ST. However, we recognize this is a device. We will load a generic sensor type profile for this device. All functions this device provides may not be accessible via this profile."

  • the user then has the most basic version of that sensor type added to their dashboard

This should reduce some end user confusion and the need to go to the IDE.

Perhaps even offer the option to “Notify SmartThings about this device” via a button. ST Support gets a notification of it logged in the database with whatever information needed pulled from the raw device information. ST can also keep track of devices that are being added by users so they can also prioritize adding them based on popularity.


(Brian) #2

Me like

20 characters!


(Robert Vandervoort) #3

This is the answer I am trying to find… I bought an Enerwave 20 amp outlet, z-wave obviously, and Smartthings doesn’t recognize it… I’ve tried for 40 minutes with the hub 6 feet away, power cycling, waiting with it on, waiting with it off, nothing… The documentation and marketing hype make it sound like you can make anything work with it but I’ll be damned if I can find anything useful in this forum or the documentation on how to use say an existing device type like z-wave switch, and create the device manually. If the hub doesn’t “see” it, how in the world can I add it? It’s Z-Wave standard and I’d think if the hub was in discovery that it would see it and be like “hey I see this thing that looks like a switch but it’s not in my listed devices list”… Something like that? But no, it just spins and spins. Even on the devices that were directly supported, my GE toggle switches, it tooke me nearly 20 minutes a piece to pair them try and try again. I had to put my hub on a 50 foot cable and move the hub around the house to get it to work. Now I understand my vera has or had, that handheld dongle to find devices… I’m on the verge of boxing this thing back up and sending it back to Amazon. Something I was originally stoked about I’m not pretty annoyed at. It’s also reporting switch status falsely… GAH!


#4

What you’re describing is one of the main points of zwave: every certified device describes its device class (such as binary switch) to any certified zwave controller. It will also describe the command classes it understands.

Zigbee does something similar for profiled devices.

And, yes, typically the controller then automatically describes it by its device class name unless there are some manufacturer-specific features it intends to support–and those are supposed to be rare!

Early on ST made the decision to add brand names to some device type descriptions. No idea why, as it then implies every brand will have its own device type, the exact opposite of what Zwave/zigbee certification is supposed to accomplish. And it leads to exactly the confusion you point out.

So I guess my first thought is all certified zwave devices already identify themselves as members of a standard device class. I would like to see that definition used somewhere in the ST description.

FWIW…


#5

Frustrating!

If the hub doesn’t see it, the problem is almost always that the device thinks that it belongs to a different network so it’s not talking to SmartThings. This can happen even with brand-new devices, because the device has to be paired to a test network at the factory in order to make sure it works, and that pairing doesn’t always get cleared.

If you contact support@smartthings.com they will help you. Usually the first step will be to do a “force exclude” on the device, which will help reset it to its factory settings. You will probably also need to do some additional factory reset on the device itself.

After that, when you do the + search, the device should at least be found as a “thing.” Even if smartthings isn’t exactly sure what to do with it.

(Sometimes the problem you describe is caused by a bad device, which can happen with any electrical items. Networked or not. But is rarer then the problem that is solved with the forced exclude.)


(Robert Vandervoort) #6

I tried the exclude steps, and same thing, nothing ever comes up. I followed the directions that came with the outlet as well. Now this morning I’m getting all bogus statuses on all my devices saying everything is turned on when its not and when I turn them off, then on then off, and go back a menu, it says they are on again and aren’t. That’s on my ipad and the “things” section on my Android phone just says an unexpected error occurred… This is a little maddening. I’m going to give support a chance before I give this thing the boot and go to Vera.


#7

If it’s during business hours, you can also choose the SUPPORT link at the top of this page, then choose TROUBLESHOOTING and there will be an option for chat in a tiny popup at the bottom of that page.

https://support.smartthings.com/hc/en-us/categories/200049189-Troubleshooting

SmartThings supports the Basic Set of zwave commands, plus a few more. Vera supports more zwave commands, and hence more zwave devices, but no zigbee. Different solutions will work for different people. But there’s no question ST support is much better. Very helpful. So always worth a try.