Unable to turn GE 12729 switch off (digitally, by app) - switch on works


(Michael Busch) #1

Hello.

I encounter a strange behaviour at the moment with one of my GE switches.
The Switch is the GE 12729 Z-Wave Wireless Lighting Control Smart Dimmer Toggle Switch.
It is connected with a GE 12728 Z-Wave Wireless Lighting Control Add-On Toggle Switch.

It started about 3-4 weeks ago, I have the switch since November 2015 and it worked fine until now. Nothing was added, no electrical work was done, neither on the switch nor anywere in the house.
Current behaviour (started about 3-4 weeks ago).

I am unable to turn the switch off by iphone app or/and by one of my SmartApps. The SmartApp is running perfectly, I shows that it gives the command to the switch to toggle off, but it never happens. Same with my iPhone-App, I am unable to toogle off the switch.
to switch it ON, its works fine.

So basicly I can turn the light on, but not off.

What does my Switch (SmartApp) do.
I have 4 sensors which monitor several doors, If one of the sensors opens, the switch shall turn on the lights. This is working fine and it’s working always at all times. Then the light shall stay on for 5min and then turn off.
This is what never happens. The logfile shows that the toggle off command was send to the switch, but it never turns off.
Same with my iPhone app (things menu) , I can turn the light on, but not off.
Manually on the physical switch, I can turn it off, no problem here.

Anything I can do to fix my problem? Any Thoughts?


#2

There are two easy things you can try. Then if those don’t work you have to start digging deeper.

One) do a zwave repair. This is just a utility that you run. It will probably take about 15 minutes to finish, but you may not see the results until the next day.

  1. shut off the power at the breaker and then turn it back on. GE switches do have a known problem where some percentage of them can become unresponsive. This usually happens a couple of months after the end of the warranty. It’s not all of the switches, it’s just a higher percentage then with other brands. If you search the forums you can find discussion of it. Don’t just use the airgap switch – – actually cut the power to the whole circuit.

It has nothing to do with SmartThings – – you’ll find the same discussions on forums of other Z wave controllers.

I’m not sure this is what you’re seeing, because the behavior you describe doesn’t quite fit the pattern, but certainly flipping the breaker can’t hurt and might help. If it does help and the problem keeps coming back, then you’re left with the decision of whether you want to flip the breaker every time or whether you want to replace the switch.

If neither of those two things help, then you have to start looking into issues like interference, excessive Polling, range, etc. but the first two are the easy ones to try so I’d recommend starting with those.


(Duke) #3

I’ve had three switches that previously had no problems stop responding to the app. I tried the z wave repair and turning off the switch using the air break. Neither worked. In the end I had to remove the switch and then add again. This is a pain because the switch needs to be removed from all smart apps and routines before it can be removed.


#4

Assuming it’s a zwave switch, you should be able to use the zwave “replace” utility without having to change all the smartapps. It’s intended for exactly this kind of situation – – where a device stops working and you want to replace it with a new one. Or even just reinstall it. (It’s possible the Replace utility wasn’t available when you had the problem, it’s a fairly recent addition.)

Also, did you try actually cutting the power at the circuit breaker, not just the airgap switch? This does seem to make a difference in some installations. ( I suspect it may have to do with the power jump you get when the circuit comes back on, but that’s just a guess.)


(Michael Busch) #5

Thanks you very much for your replies. It’s greatly appreciated.

I think I got it fixed for now, I have to figure out why an other switch is not working since I tries out your suggestions.

I believe the solution was a combination between everything I did. Most of the suggestion I did prior, but not all together.

First I checked manually on the physical switch, that I can turn on and off the light. It worked. Then I checked online that the hub recognized the two events. It did.
Then I turned the power of, as suggested above and restarted the hub during this time. After about 20min the hub was back online, the power was back on and I started the repair-function.
Additionally I have to mention that I took to liberty to remove 2 devices prior to rebooting the hub. One was a not-working motion detector (I never got it to work at all) and a range extender, which I believe never worked too.
I waited about 30min for the “repair” to finish, then I tried it out with the iPhone app, it didn’t work at first. After I manually switched on/off the lights physically I tried the app again and to worked again. Even my rules are working now again (the turn off part).

So I am happy. ok, 50% happy, because I tried all switches and of course (Murphy’s Law) one is not working. I will take care of this one tonight. It’s a light switch I rarely use.

Thanks again
Michael.


(Duke) #6

I tried the replace function and received an error message that stated I needed to make sure the device was added to the hub. Assuming the hub was not seeing the switch, I added a new device and it accepted. Weird that the hub lost this device completely as it had been working for several months.


#7

Had a bear of a time getting this device to work correctly. It kinda turned off with Alexa & the app but wouldn’t turn it on. Plus the status was always wrong. Manual worked fine. Just wanted to pass on that after removing repairing excluding over & over again, the CORRECT way is removing the device from all smart apps, then from ST, then excluding the device, and then resetting the circuit breakers before re-adding the dimmer. Once again @JDRoberts was correct!

Will install another 12729 (this time in a 3-way configuration) tomorrow. Hopefully it’ll go a lot smoother.