Unable to control WiFi devices after changing WiFi mesh (Dec 2023)

I replaced my WiFi network with a newer model. I used the same SSID and password. I can control my Zigbee deadbolts, but not the WiFi connected devices with the SmartThings app. I am able to control them with my Alexa device and app. This is real odd…in the SmartThings app, I can see the status of my light switch. So when I turn it on manually, it shows it’s on. But when I tap the control in the app, it says a network or server error occurred. Try again later. I’ve power cycled the SmartThings hub and signed out and back into the app. I’d rather not delete and re-add all of my devices to SmartThings. I know the devices are fine since Alexa can control them. Does anyone have any ideas how to fix this issue? Thanks!

That sounds really frustrating! :disappointed_relieved:

What’s the brand and model of the Wi-Fi switches that aren’t working? And are they still on the same Wi-Fi branch as your SmartThings/aeotec hub?

It’s happening with multiple WiFi plugs and switches. One example is the TP-Link KP100. I have a few, all on the same WiFi network. Like I said, I know the smart plugs are working fine as the Alexa app can control them. And it’s so odd that the ST app can see the status of the switches. It just can’t control them. Hard to tell where the signalling is failing. And it only fails on WiFi. My three zigbee deadbolts can be controlled properly.

What brand/model for your Wi-Fi did you upgrade to? Have you checked firewall or routing rules in the new system? You rebooted your ST hub if you have one?

I installed a TP-Link Deco M5. I don’t see any firewall controls in the app. And they work with Alexa. It’s only in SmartThings that it’s failing. I have power cycled the SmartThings hub a few times. Nothing that I’ve done has changed the symptoms.

Probably due to change in IP addresses of the devices. Do you use the official kasa integration or the community developed driver for kasa?

When I mentioned reboot earlier… I was referring to the option available through the advanced web app to reboot the hub vs the harsh power cycle .

1 Like

I finally got it working again. I changed the WiFi mode to access point. Router was the default. I thought for sure that would fix it. I then unlinked TP-Link/Kasa from SmartThings and then connected it again. Boom! All the devices were then controllable. I still had to assign rooms to each device and fix the routines. Not a huge deal. Kind of surprised SmartThings couldn’t handle the change in my WiFi network.