Unable to connect Schlage wave door lock to smarthings

Sometimes doing a factory reset on the lock itself will help in the pairing process. I personally have had to do this on my locks.

@Carter_Nabors Did you get the lock installed?

ive done that… a lot of times… still no go

lock still does not work… sorry for the late response. I’ve tried batteries, and it is not in any other room… it says it is “using low security” but when i click on it it says the lock has not updated yet and doesn’t update at all.

On my second lock, i got the low security warning, too. Eventually, it started updating. I think my front door was purchased first. I am guessing different version numbers, but not sure how to confirm or how to update.

This is what I get when I click on the lock… it stays like this

I am likely wrong, but that locks like the default Zooz drivers, not the one from i believe from @philh30. Click on the three buttons in the upper right corner. Do you see the option to switch drivers? If not, then it is the old driver.

I checked… there was no option to “switch” the driver

Can you show us the device details from the API Browser+ please?

As with another lock in another thread, the all zeros for the fingerprint (Mfg Code and Model) are a tell that the lock did not register properly with the hub and you will notice that a DTH driver has been installed instead of an Edge driver. In my experience, devices with all zeros fingerprint require a factory reset and sometimes also an exclusion after to get the device to add properly with an Edge driver.

1 Like

to confirm, factory reset is just unplug press schlage then add power and see 3 lights flash right

Yes, the Schlage logo on the keypad.

I was unable to connect it again, same thing as before… not using high security and not working. Ive done a freset and an exclusion before all to no avail…

From earlier in the thread, you said you have a BE469ZP and that model supports S2 security. Did you add by brand or by Search nearby? I had no luck iwith that same lock if I didn’t enable the security using either the QR code or entering the pin manually.

I added by brand, the search didn’t work for me. I’ve tried to enter the code, but my sticker is practically peeled off so i cant tell exactly

magic! The 8 on the code had scrapped off into a 3 so I had been entering 3 this whole time! Thanks for everyone’s help and I hope this article can prove useful for people later!

1 Like

one last thing, the device says some features haven’t updated yet… the lock locks and such but the codes and alarm state and other options do not work… is this meant to work or no

Pull down on the device panel several many times. The way the device handler queues up the attribute requests is too fast and the Z-Wave commands timeout before the lock can respond. You can see that in the driver logging via the CLI.

Also, @philh30 suggested using a routine to set one of the attributes of the lock so then the lock would report back its status.

1 Like

Sick thank you sm

1 Like