Getting frustrated trying to get the ST hub to work with any z-wave devices

So I just got my ST, via the $50 Amazon deal, and have been trying in vain to get it to connect to any z-wave wave device I have.

I first tried to get it to connect to my Schlage Connect deadbolt, which I eventually could get to show as a Z-wave lock, but would not report status or unlock via ST. I tried excluding the lock and re pairing, I tried a factory reset on the lock, I tried bringing the lock within a few feet of the ST, and excluding and repairing, but same result.

I also tried adding a Schlage rp200 plug in dimmer switch, excluding, and repairing, moving it within a few feet of the ST, but again, no dice.

I also tried pairing an Aeotech plug in switch, excluding it and repairing it, but again, the ST could not get its status or issue commands.

I’m coming from a veralite and adding these devices was very simple and worked immediately.

Am I missing something? Did I get a dud of a hub? Any suggestions?

I don’t see that particular model name on the list of compatible devices however, you might try looking here for additional info on connecting Schlage locks to SmartThings.

Also check here for all officially supported devices.

That being said, the community has done a lot of work towards integrating devices not officially on the supported list. You may find someone that can help even if your devices are not yet officially supported by SmartThings.

Should work easily. However call ST support or use live chat they are quite good.

I don’t know about the Schlage outelts.
Schlage locks while IMHO the best ZW locks available are very very picky when it comes to getting them included initially. What DTH and App did you try using for the lock ?
How old is the lock ? What FW version does it have ? Some of the early models did have a known FW issue that requires it to be sent back to Schlage for an update.
Aeotec should connect and work fine with the standard DTH. If it just pairs as a “thing” or ZW outlet you should go into IDE and change it.

Yeah, I followed the instructions in your link, from general exclusion to repairing. After a lot of googling, this should work easily with no issues.

Really sorry you are having so much trouble. Perhaps you should reach out to support via chat. They are really helpful.

Hey all, just thought I’d come back to this thread and report that I spent around an hour and a half chatting with ST customer support (which, I have to say was fantastic, they are super helpful), but could not get anything to pair, so they sent me a new Hub. I just got the hub last night and blammo, all is fixed and all z-wave devices now pair easily!