Unable to change temperature metrics [opened support ticket no response]

Hi. I am new to this community, so getting the hang of how it operates.

Challenge. All temperature metrics are showing F and I need it in Celsius. I have gone to the “home” settings and tried to change the temperature settings but as soon as I click “done” to submit the change it does not do it. It is unresponsive. The same happen from different browsers, and from the APP.

I have raise 2 support request to smarthing team, but not response.
Sent: Friday 30 September 2022 20:54 To: support@smartthings.co.uk Subject: SmartThings Support - unable to change profile settings

In the meantime, I found that my samsung account profile has the “country” set to US. I have open another request with Samsung Account Team, to make the change to the correct country. I would hope that this setting would be connected to the fact that smartthings is taking it from my account locale … but that is just a guess.

Has anyone come across this issue and what is the support route to Smartthings… I have also tried ringing samsung and automatic message sends me back to the website for chat support, which when I engage tells me to open a ticket via email, which I did with no response… so I am not progressing anywhere really.

Thank you

Does anyone knows if this community forum is monitored by samsung?

I am looking for guidance as I am not sure what else to do to get help. I have raised a ticket with samsung smarthings uk, they do not respond. Samsung smarthings.com was very quick to respond but told me that i need to contact smartthing uk… so i am back into a loop now with this…oh yeah… also tried the support phone number and because its smartthings they send in the direction of email support…


It is not, as far as regular support requests.

This forum was set up many years ago so that customers could help other customers with ideas and questions. With a few specific exceptions, it’s not an official support channel. There are some SmartThings employees who post here from time to time but no one who is assigned to pick up regular support requests.

The best way to reach official support is through the Menu option in the SmartThings app, then the “contact us” link. Different contact choices are available in different countries.

Be aware that the first people you talk to are just general Samsung support reading off a script, who don’t necessarily know anything about SmartThings. So it may take some back and forth until you get a support staff member who can really help.

In your specific case, I believe it does still take a support staff member to change the country your account is assigned to, but I’m not 100% sure that’s still true. :thinking:

Good luck! I know there have previously been community members posting about issues with Fahrenheit vs Celsius, but I don’t know the resolution. I really just posted to answer your question about the nature of this forum, which is peer to peer help.

1 Like

Also, it might help answer your question if you tell us the country your account should be assigned to. If it’s a country where SmartThings is not officially supported, that could be part of the problem. :thinking:

If you are in the UK, this is the official support page with contact choices, again with the caveat that the first people you reach will probably just be working from a script. This may be the same one you already tried, but just in case, here it is.

Another thing some people have tried in the past is to contact one of the public facing marketing channels, like Facebook or Twitter. Those at least are monitored by Samsung employees. They might be able to at least get you in touch with somebody from support.

Thank you for your replies @JDRoberts.

I am in Ireland. The country in my samsung account was already rectified by samsung via a support ticket. Apparently country can only be adjusted by them and not by the user.

That had no impact in Smartthings… i am still not able to change the temperature settings… its strange because the issue is that when i hit save/close after the setting is changex, it wonde react… i can see the button being activated, there is a refresh wheel but the page never load or the frame closes. This happens via the browser in multiple devices, so i doubt its device related…

1 Like

oh as far as I remember it’s impossible. there was an old thread on this, and only a few lucky users got it sorted out. I moved more than 5 years ago and still have my weather in Fahrenheit.

On the positive side, US servers get new features first

1 Like