Temperature format - one showing C, another F


(Ant) #1

Hi,

I have set the temp format in my hub (via https://graph-eu01-euwest1.api.smartthings.com) to degrees celsius but this has only updated on one of my sensors. I have also tried setting this value a few times but no joy.

My motion sensor is showing the correct value (20) but my multi sensor is still reporting in F (73). [They are in different rooms so expect to see slightly different values].

Is anyone else seeing this behavior or do i need to report to support in case there is an issue with my multi sensor?

Thanks,
Ant


(sidjohn1) #2

Yes contact support, it’s most likely a configure issue not a hardware one.


(David Tucker) #3

Same here - multipurpose sensor only shows F and there is no visible option to change it to C


(Ant) #4

will let you know what support say when they get back to me - Live Chat is currently unavailable as they are ‘too busy’… hopefully busy fixing the Oauth issues!! :yum:


ST Multi Sensor Problems
(Aaron S) #5

Try live chat on the Samsung UK site between 10a-7p. Youll get a local team with British spelling.


(Ant) #6

At this point spelling is the least of my concerns…

I just had a reply from the USA support team at nearly 11pm telling me they have pushed my query to the UK team - the same UK team who were too busy to live chat and likely now shut - this just makes no sense. Why even reply to me telling me this?! I now know someone has looked at my email and just decided to push it on without adding any value.

Id also like to add that the email address that i was shown when live chat wasn’t available is the one i used, which somehow routed my email to the wrong queue?! seems your Zendesk implementation isn’t particularly ‘Smart’ either. Why even show me an email address that routes into a USA queue if it needs to go to a UK queue? You know where i am based as i am logged into the SmartThings app to request a chat in the first place… Is any part of the SmartThings set up actually ready for the UK market?! its quickly gone from slightly frustrating (but almost acceptable for being an early adopter) to actually annoying on a personal gripe level. I am at a point where i feel it is almost my duty to start a UK focused ‘awareness trial’ [read awareness campaign]… using all the effort and time i had allocated to building my smart home & rules as its clear that i will have all of that time back on my hands to kill…


(Aaron S) #7

Sorry for the confusion! US and UK run separate hours for live chat. The chat platform used in the UK is different from that in the US and is not set up for in-app support. If you update the SmartThings app, the link has been removed to prevent further confusion.

Additionally, if customers accidentally contact the wrong country, the other team would typically provide you with initial troubleshooting steps and do a more subtle handoff. However, the C/F issue appears unique to the UK (or at least not trending in the US) and we are still looking for a fix/workaround (and root cause) in the UK. @adgwill - it looked like J wanted to get you bumped over to our agents right away and T & I are digging into this with the engineers on your behalf.

Thanks,


(TC) #8

Is there a solution to the C/F problem yet? I am seeing the same thing.


(Ollie) #9

I’m also seeing this issue, where my location is set to C. My motion sensor is now showing temperature in C but my multi sensor is still showing F. In addition, the software colour ramp is confused by Celsius values - it’s showing the colour as if it was am F reading - i.e. 22 © is showing dark blue (extremely cold) whereas it’s actually 72 (F) and should be showing with a green (i.e. normal temperature).


(Ant) #10

Hi @Ollie

I never heard back from Support and just removed & re-added the sensor a few times and after a couple of tries it started reporting back in ©. I would strongly suggest trying the same & will keep my fingers crossed it resolves for you also!

I wonder if by re-adding the device after the default temperature format has been set to degrees C makes a difference.

Ant


(sidjohn1) #11

Yes, this makes a HUGE difference.


(pillock) #12

I had the exact same problem - Added sensors, then changed my Location preferences to C from F, and my sensors were still showing F. Which was a bit of a shock, as I have a multi sensor in my fridge to alert me if the door is left open, and apparently my fridge was at 49 degrees…

I noticed that if I put a temperature offset in, it changed it to C - I put -3, and instead of dropping to 46 degrees it went down to 4 or something. So I took the offset out, and it stayed at C.

With my moisture sensor, I just put an offset of 0 and it forced it to C.


(Flip Taylor) #13

I’ve been having this issue too since I first got SmatThings. Fixed with todays update :grin:


(Gordon ) #14

My temperature sensors all show the correct temperature with a ‘C’ but notifications and text messages show ‘F’ after the same figures. I must plead guilty to initially setting up with F before realising where to set things up for C.


(Iain) #15

I’ve had this issue and tried various combinations of the tricks in this thread with no proper results.
Started out with multis in F and switched to C in the site. After some days they switched to C, but at this point I realised my movement sensors were still in F.
Left it for a while longer.
Found my site setting was back in F again, switched it back to C.
Now my movements are in C and my multis are F.

I’ve bee in contact with support and they’re aware of the issue and that it’s being worked on. They say they “don’t have enough pointy stick” to keep on at the devs, I’ve suggested perhaps tin cans on string would promote some two way comms but apparently there’s no schedule for a fix forthcoming.

I’ve also got Honeywell Evohome and waiting for that integration before this becomes too annoying.

It’s now been months that this thread has been running, is anyone else still having these issues?

Thanks,
Iain.


(Aaron S) #16

The challenge had been with pinning down the root cause. It’s not clear if this is happening on the platform side or with the device handlers. Keep emailing support@ when it occurs so we can trend events. Thanks!


(Duminda Jayasena) #17

I’m using the UK Hub V2. For Multipurpose Sensor, firstly temperature was in Fahrenheit. Then I changed it to Celsius on Location Settings. But it was still showing in F.

Then I removed the sensor & paired it again and it’s now showing the temperature in C.


(Iain) #18

I did nothing, just waited a further two weeks and today my sensors are all in Celcius. Long may that continue.

I.


(Glenn Smith) #19

When I first installed it was F and changed setting as per help pages and waited for next temp change to trigger change and it didn’t work. I then removed the sensor and repairs by taking battery out and it was C. To be fair future sensors all reported in C from the get go.


(Mack) #20

Hi all,

I had the same problem as above… temperature was in F. What I did was:

  1. opened website: https://graph-eu01-euwest1.api.smartthings.com
  2. loged in with smartthings login and password
  3. once you are logged in on the website navigate to the top left corner and click on “My Locations”
  4. once the new pages opens, under the picture click on “Edit”
  5. then from the dropdown menu under “Temperature Scale” choose C
    6.Click on update.

Now you have to remove the sensors from the Smartthings app and add them again. (it won’t work otherwise).
After all is completed and after the first activation of the sensor the temperature reading will be in Celsius.

Hope this helps!
Mack