Unable to add new z-wave devices

I’m trying to add a new leviton dz6hd device(already have 9 installed). When doing an inclusion the light flashes 3 times on the leviton switch like if it worked but on the app (classic) it never appears. I have to do an exclusion and try again but without any success. Tried using an iphone and android phone, rebooted my hub, changed the location of the hub, tried repairing the z-wave network even tried another new switch nothing works. Any ideas?

I’ve been able to add zigbee devices though

any custom device handlers? if yes, try opening them and publish for me again. then exclude and try to pair.

if that fails, look at your logs in IDE when trying to pair to see if any errors show

nothing special in the log I can see the device when i press the switch but unable to add it

Found a way, not a easy or fast one but it seems to work. I excluded every leviton switch i have and then everything seems to work now, I added back every switch and have been able to add the new one. Now I have to set my automation’s back…