UK Light switches – My experiences (2020)


I accept your point but these switches are specifically described as being good for the UK.

I have located some switches from the UK and sya they are designed here in the UK now, rather than the dodgy ones from China via Amazon. I will try that.

Thanks for the feedback

Glad to help.

It’s a pain but there is a fairly good range for ‘no neutral’ connections now. Just make sure it states that.

1 Like

I thought I had found one and have even ordered it, but then in the small print it mentioned the capacitor to fit across the L1 line, which did not work for me on the first try. On further viewing I think it is the same as the Yagusmart one.

What would you recommend?

Simon Thompson

There are lots. Lightwaverf I put at the top end and have a few of these myself, but then I have a mix of things such as sonoff minis and other zigbee and WiFi no neutral switches as my project as grown and grown.
If you like Yagusmart, they even do a version of no neutral

If you’ve already ordered those, give them a try. I have 1 switch that said it ‘might need’ the capacitor across the lamp - it didn’t and works fine.

1 Like

Switchboxes in the UK can be wired for either “2 wire” (no neutral) or “3 wire” (requires neutral) devices. Usually older boxes are 2 wire and newer ones, in homes built in the last 5 years, are 3 wire, but you do find both, sometimes even in the same home! So either kind of device can be “designed for the UK.”

Most smart switches require a neutral because that’s how they power the radio. But as @Mikeyf79 mentioned, there are some models that will work without a neutral. :sunglasses:

The terminology is confusing because the earth is not counted as a wire even though it looks just like all the others except for the colour.

Also note there is always a neutral somewhere: that’s what completes the circuit. But an older homes it was quite common for the neutral to just be a return wire from the ceiling fitting. The other wire, the “live“ was just cut at one point and the wall switch installed there. When the traditional dumb switch is on, current can flow to the fitting and then on through the neutral. When the traditional dumb switch is off, no current flows to the fitting from the switch.

Vesternet has a good article on this:

1 Like

Might there also be something in the communication method. I note that Vesternet uses z-wave and Zigbee protocols and Yagusmart uses WiFi.

Simon Thompson

Protocol doesn’t affect the wiring, many companies use exactly the same case and just swap out different radio modules for different protocols.

Vesternet is a retailer like Amazon, they carry many different brands and protocols, including some WiFi devices.

Yagusmart makes both Zigbee and WiFi models. They sometimes look identical. They make Zigbee models for both 2 wire and 3 wire setups, so you do need to read product descriptions carefully. :thinking:

1 Like

Old wiring in UK houses - including my own house does not have ‘two neutrals’. Many smart light switches and especially dimmers require the wiring to have two neutrals so power can still reach the smart switch even when the lights themselves are turned off.

Either you need your light switch cabling to have two neutrals or you need a smart switch specifically designed to only need a single neutral connection. It appears in your case neither is true and therefore it is not working.

Your options are either to return these smart switches and get different ones that do not need two neutrals or to get the electrical wiring replaced.

Technically these switches are going to be UK compatible but only if you haver newer style wiring with two neutral connections. I believe this is now fairly common on modern homes and installations. As mentioned my own wiring lacks two neutrals but I plan to have my wiring upgraded along with other work.

I’ve never heard the term “two neutrals“ in this context for either UK or US wiring, and I want to make sure the OP doesn’t get confused.

The typical terminology for the UK is the one used in the Vesternet article linked to above: “two wire,” which means no neutral at the switchbox, or “three wire,“ which means there is a neutral at the switchbox. But there’s only one neutral on the circuit, it’s just a question of where it’s attached.

And there will be only one neutral wire coming into the switchbox for a single circuit.

Again, the Vesternet article has diagrams that show this clearly.

Do you have a link to a reference referring to “two neutrals“? I’m wondering if this might be someone’s own terminology for a three wire set up where you can find a neutral at both the switchbox and the light fitting. But it’s the same neutral for the same circuit, it’s just pulled down all the way to the lightbox so that it’s available there as well.

I think many suppliers are being economical with the truth when they claim UK compatibility.

Simon Thompson

1 Like

This thread is starting to get silly now.

There is no such thing as 2 neutrals. And nothing needs 2 neutrals to work.

In fact neutral is very rarely switched in any circuit in a UK home, only the live is switched. The neutral is directly connected to device. About the only thing to have a neutral switch is a cooker switch (I.e. it switches/isolates both live and neutral).

This is why we don’t have a neutral at our light switches, because it’s permanently connected to the lamp. (Thats the correct electrical term for a bulb before anyone says any different). As my apprentice master used to say many years a go “a bulb is how you grow flowers, that’s a lamp boy”.


I’ve got one of the Yagusmart switches off of Amazon…and also am getting the 2 minute turn-off issue

I’ve tried all of the DTHs (zigbee switch, zigbee multi switch power, zigbee multi switch) (Deleting in between attempts)
I’ve tried using the amended versions with the isOrvibo() returning True
I’ve tried pairing multiple times etc…(with and without deleting devices in between attempts)
Nothing seems to prevent the 2 minute turn off

Am starting to go slightly mad…Did anyone find a consistent way to make these single Yagusmart switches work?

If the switch isn’t paired to SmartThings then it will stay on past 2 minutes…but kinda defeats the object…

Here’s the type info for the the one I received as it shows up in the IDE:

  • zigbeeNodeType: SLEEPY_END_DEVICE
  • application: 41
  • endpointId: 01
  • manufacturer: _TZ3000_9hpxg80k
  • model: TS0011
  • onOff: catchall

Best regards


When you changed your DH did you updated your device throught Smartthings IDE? For example change device type for one random type and back again to your modified DH?

Have you added the fingerprint of your Yagusmart to the DH?
Can you share your isOrvibo lines?

Yes all the changes were made through the IDE. As I mentioned I’ve switched between multiple DTHs and at various times deleted the device and re-added.
I didn’t specifically change the DTH to something random and back again when editing the DTH code - I’ll give that a try though

On the edited multi-switch DTH the isOrvibo code is as follows:

private Boolean isOrvibo() {
return True

I’m using a modified DH of “Zigbee Multi Switch” and I had to change line 255 (252 on the original DH) to this:

private Boolean isOrvibo() {
device.getDataValue("manufacturer") ==  "_TZ3000_fvh3pjaz"

Basically I changed the device model after device.getDataValue(“manufacturer”) == from "ORVIBO" to "_TZ3000_fvh3pjaz"

I also added the fingerprint of my Yagusmart to the beggining of the modified DH (it’s not mandatory):

// Yagusmart
// Raw description 	01 0104 0100 01 04 0000 0004 0005 0006 02 0019 000A
fingerprint profileId: "0104", inClusters: "0000, 0004, 0005, 0006", outClusters: "000A, 0019", manufacturer: "_TZ3000_fvh3pjaz", model: "TS0012", deviceJoinName: "Yagusmart Light Switch 2 Gang"	

You can find this info on your logs, try it.

Alas, no cigar…
I realised I’d made a typo in my code in that ‘True’ isn’t the same as ‘true’…

So once corrected my isOrvibo basically returns true regardless (i.e. isn’t limited to manufacturer = _TZ3000_fvh3pjaz)

I’d added the fingerprint to my handler so when I add the device it automatically picks that DTH…

but I still get the two minute turn off…

Have started to pull out my hair :frowning:

So, I finally gave up…deleted any DTHs I’d created as part of my experimentation and switched the device back to the stock “ZigBee Multi Switch Power” as it was late, with the intention of putting the original dumb switch back in the following morning…
Did a final check - still had 2 minute turn off problem.
Following morning as I was going to disconnect the switch - I tested it again…I don’t know why…but it stayed on…hmm…
Its worked fine ever since…(apart from the fact that obviously the DTH means it shows 0W power as the switch doesn’t support power monitoring…(I can live with that))

So it appears there must be some other factor involved when messing with DTHs etc that time appears to fix…
Confused…no clearer as to ‘what’ made it work…but it works…so thats something…

There is a known issue with custom DTHs where a DTH can get “stale” and you will be stuck on an old version and new code changes will not be applied. It sounds like that’s what happened to you. It’s not clear why this happens, it has something to do with the cloud.

Sometimes the only fix is to delete the device and re-add it so it picks up the new DTH. Which again sounds like what happened to you.

It seems more likely to happen if you have more than one DTH with the same device fingerprints.

You can search the forum for more discussion, but I don’t know if anybody knows more than that. :thinking:

Over the course of my fiddling I deleted and readied the device several times (as some DTHs appear to create child devices and others do not)
When I had multiple custom DTHs I only ever had the fingerprint un-commented in one at a time
I was spreading comments liberally through the custom DTHs so I could try and track what was running under what circumstances…and certainly sometimes I didn’t see things going on so that sounds like the ‘staleness’ you were talking about.
But given deletion of a device and re-adding I’d have thought that I’d have got round that issue.
Some other weird behaviour I saw was that occasionally the add procedure wouldn’t complete (in the Smartthings app) but I’d see the Alexa message saying it’d spotted the new device…so it had clearly finished but the app hadn’t twigged…this again made me think there was some ‘time’ element to all of this?
I just read the linked article you posted properly :wink: And it pretty much describes everything I’ve said…

Hey ho…you live and learn (or try to anyway)

Thanks JD

1 Like

Regarding rotary dimmers that fit and work like traditional rotary dimmers, I can vouch for these from Candeo.

I’ve set up a few and they work great with Smartthings, or Philips Hue.
Plus 2 way dimming with a retractive switch as a 2nd swtich.