Two lousy devices and already fed up!


(Steve) #1

I have one Smartthings Hub v2, and one Leviton decora z-wave plus smart 1000w dimmer (DK1KD) so far, and I am already reaching my limit for frustration.

Hub is connected and live, although the “Smartthings” app always shows it as “no network connection” until I tap on the icon for it, then it shows “CONNECTED”. This is randomness #1so far. The hub is ethernet connected and registered and seems to be working.

I installed a Leviton decora smart z-wave plus dimmer switch (same room, opposite wall, maybe 30 feet away), connected to the outside flood lights (two dumb flood bulbs). I ran through the “pairing” process to get the Leviton dimmer added to Smartthings (a name I already find questionable), and it was added without error.

The dimmer now shows in the Smartthings app as “Leviton Dimmer Switch” (I know, very creative . . .). I am just trying to understand how this stuff works right now.

Ok, so two devices in Smartthings app. I can tap on the dimmer icon and turn it off and on (with extremely unacceptable delays involved). I can then dim or brighten it from the app as well, so it is recognized and working.

THEN. I tried to set up one simple automation.
I was going to add an automation to turn on the dimmer at 60 minutes after sunset.
But the automations app says there is no device for it to act upon. Blank list, nada, nothing.

I started with Add Automation, Home(1), Smart Lights, New Lighting Automation, and the app comes up with:
Which devices do you want to control?
None available

Fun, fun, fun.

So I tried Custom Automation.
Based on the time of day
Set the time for 60 minutes after sunset
Under the “Then” heading, I hit “add”.
I selected “Control a device”
it shows No Devices

I deleted the Leviton switch and reset, and re-installed, and and re-paired, and started over (three times). No dice. Same crap again.

I am already to return this so called “Smart” stuff and forget about the whole thing.

WHAT AM I DOING WRONG???


(jkp) #2

I bet you are using the new SmartThings (Samsung Connect) app. If you are, I highly recommend you install the SmartThings Classic app and use it.


(Dan) #3

Use the SmartThings Classic App.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #4

What you’re doing wrong is not having enough patience, and having too high expectations. SmartThingsany home automation – is really incredibly complex (and magical).

The marketing may set expectations that this is all intuitive, but it is not. Particularly with differences between the SmartThings Classic App (highly recommended!!!), and the “new” SmartThings (Samsung Connect) App (not recommended; it is incomplete and changes too rapidly as they are building it out).

Folks here will walk you through stuff (and I’ll bet there are a 100 videos on YouTube…); and everything will probably work out fine. But only if you have patience. Because it only gets worse as you build out your smart home and make it more complicated; but the patience and effort is rewarded with results.


(Steve) #5

I wouldn’t call wanting a (Z-Wave plus certified)hub and a (z-wave plus certified)switch to work together “high expectations”. All I want from this is to be able to turn on and off an outside light.

I will remove the Smartthings app and install the classic app and start over.
Should I delete (exclude) existing devices (Hub & switch) before deleting app?

Thanks


(jkp) #6

You don’t need to remove the new app, you can simply install the old one. They both use the same username/password. The devices will be available in the old app so no need to delete or exclude them.


(Steve) #7

Thanks jkp.

I’ll try that.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #8

Yup… But, really, it’s not unusual for new SmartThings Customers to have the same poor experience as you… And most get through it.

Hopefully using Classic App will help - While the new App works for some people, I certainly recommend against it.


(Steve) #9

Ok, this just my opinion, but I believe that Samsung really needs to rename the newer app “Buggy Beta Flaky Broken App” so that no-one stumbles onto it like I did.

I deleted it from my iPhone, installed the “Classic” version, reset my hub to factory defaults, reset my Leviton switch to factory defaults, and started from scratch. Added the hub. Added the dimmer.

It all worked. No drama. No struggle. Just worked.

So I added an automation to turn on the dimmer at 70% one hour after sunset. And one to turn it off at one hour and ten minutes after sunset. The buttons it created for these actions work when pressed, so now I am awaiting the time triggers to see if they work.
I am wondering what the left-hand icon (two boxes over one another) in the toolbar of the classic does? I select that and it just says “Connecting” and never does anything. Well, maybe not “never” but certainly not in ten minutes or so I was willing to wait and see. . …


(jkp) #10

(Steve) #11

Interesting. On my iPhone, it doesn’t even say “Dashboard” under it. It is just two boxes.
And it still doesn’t go anywhere.


(jkp) #12

try installing Smart Home Monitor in Marketplace: SmartApps: Safety & Security and then see if your Dashboard loads

check that your location is set


(Mark) #13

That’s a bug. Other people have mentioned it, I’m affected by it. I reported it to support once, they gave me a bit of a run around re: updating iOS and reinstalling the app. It doesn’t really bother me so I didn’t feel like doing that.

The blank icons should have labels too, like this.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #14

Lots of us have this opinion. But Samsung isn’t influenced by us.


#15

If you have a Samsung brand smart TV, Samsung brand smart appliances, or the Samsung brand wifi router, then you have to use the new app, at least for initial setup. Hence the company’s dilemma. But, yeah, it’s a mess right now.


(Darren Baker) #16

tgouchat, you just saved me! I needed to add 8 Sengled Classic bulbs for my new chandeliers but SmartThings would not pair them. Spent the entire evening trying to figure out what was wrong because I have 20 other Sengled bulbs around the house that paired last December just fine. Then I saw your post and realized I was using the new App on my Android smartphone. Installed the Classic app and it worked immediately!

Listen to tgouchat, don’t use the new app unless you want trouble.