Turn off energy usage readings

Sorry if this has been asked before. I couldn’t find a post that applied to my setup (I think I saw a similar post for ST Hub v1, which I don’t think applies to v2).

I have an Aeon Labs Smart Energy Switch hooked up to a 2nd wifi router (so I can turn the wifi off and on with ease…i.e. when it’s the kid’s bedtime, etc). The energy readings are nice, but it’s pulling readings every few minutes and it’s flooding my activity feed with them. Once an hour would be nice, but not every couple of minutes. I saw some instructions on turning this off by editing device type or something along those lines, but I don’t see a place to do that with the ST Hub v2. Is there a way? Thanks!

The reporting is controlled by parameter 111. What you can do is go into the IDE and create a new Device Type from Templates and use the Aeon Outlet. The default reporting time is 300 seconds (5 minutes) so you can change this to whatever you want. You would then set your device to use this modified device type. The line you want to edit is below with the value bolded:

zwave.configurationV1.configurationSet(parameterNumber: 111, size: 4, scaledConfigurationValue: 300).format(), // every 5 min

Thanks Chuck. I just made that change. Will test it out when I get home. Thanks again.

This is my first time adding a new device type, so pardon the simple questions. So I edited the Aeon outlet device type and changed the 300 seconds to something higher. Saved it and published it “to me”.

My question is how do I assign that device type now. In the ST app I go to the existing thing that has the original Aeon device type and I don’t see a place to change it. So I deleted that thing and when I go to connect a new device, I don’t see the Aeon outlet device type. Thought there would be an option for “my device types” or something like that.

Let me know if I’m doing something wrong. Thanks!


In the My Device Types when you edited the standard Aeon Outlet did you save it as a different name? If so when you go back to My Devices, click on your Energy Switch then click Edit at the bottom of the screen. The Type dropdown will have all of the Device Types. Any custom ones should be shown at the bottom of the list.

And I might have mis-informed earlier I am using the Z-Wave Metering Switch not the Aeon Outlet template for my Smart Energy Switch.

Thanks Chuck. I think I figured it out. I was looking for a place to change the device type within the ST app. When I couldn’t find it, I tried looking within the IDE page and found the spot where I could change a device’s device type.

I did notice that mine used the Z-Wave Metering Switch. Should I be modifying that one or do you think using a modified version of the Aeon Outlet would be okay?

Hey Chuck,

So I went back in and made a copy of the Z-Wave Metering Switch. The lines to change the time look like this now:

        zwave.configurationV1.configurationSet(parameterNumber: 101, size: 4, scaledConfigurationValue: 4).format(),   // report power in watts
        zwave.configurationV1.configurationSet(parameterNumber: 111, size: 4, scaledConfigurationValue: 43200).format(), // every 12 hours
        zwave.configurationV1.configurationSet(parameterNumber: 102, size: 4, scaledConfigurationValue: 8).format(),   // report energy in kWh
        zwave.configurationV1.configurationSet(parameterNumber: 112, size: 4, scaledConfigurationValue: 43200).format(), // every 12 hours
        zwave.configurationV1.configurationSet(parameterNumber: 103, size: 4, scaledConfigurationValue: 0).format(),    // no third report

In a nutshell I’ve changed the two references to 300 seconds to 43200 seconds (which is every 12 hours). Saved it and published it to my own account. Went to the device and edited it and switched it from the old device type to my new device type. That was like 5 hours ago. It’s still reporting every 5 minutes. Is there something I need to do after making a change to the device in the IDE before it takes effect? Thanks.


If there’s a flag I can change that will turn off the energy reporting altogether, I’m fine with that too.

Have you tried re-pairing the device now that you have the custom device type published?


If I’m not mistaken, if i un-pair and then repair the device, it wont pair with that new device type that I modified. it will pair with the one it detects. Then I will need to go into the device from the IDE and select the new device type, which is what I did originally.

Is there a way to get the new modified device type to be listed under the devices list when I try to connect a new device from within the app?


I’m still learning the terminology. So when you say re-pair the device, do you mean delete the device from within the app and then do the whole ‘connect a new device’ to add it back?

Yes, exclude and readd it to the hub. It should use your custom device type before using the ST one.

The devices that you’ve published to your account will take priority over the ones in our system.

Awesome. It works now. Thanks Tyler, Matt and Chuck!