Troubleshooting Aeon Labs Home Energy Meter v1

Yes I realize that, but I can’t understand how the Gen 1 is now $10.00 cheaper than Gen 2. I guess I can save for Gen 2. Since it does have more options.

1 Like

Hem 1 is still available for dirt cheap…

I’ve purchased quite a bit of kit from these guys…

1 Like

Can someone tell me how to eliminate the battery as I have it plugged in and it says “0” Battery and prefer it not show at all. I am using iOS. Thanks.

Here’s an updated version of mine without the battery tile:

With the new version of the app for Android and iOS, you shouldn’t need to change a thing, but just in case look at lines 83 and 104 in the code. It’s self explanatory on what to change.

You also have to comment out > capability “Battery” otherwise you get this in the new iOS app:

1 Like

Ah good catch, thanks! Github code has been updated.

Thank You John that does it. Is there a way to increase the size of the text for the 'min was" and Watts data was reset on"? on the iPhone the text is very small and almost impossible to see.

Take a look in the code at lines 84, 88, and 105, you’ll need to change the first two ‘standardTile’ to ‘valueTile’ without the quotes. Problems with how iOS renders text differently from Android.

1 Like

Thanks, did it in the IDE works great. Would you please provide the Github settings so I can add it to the repository for future updates.

Hi @joelw135 and @Jimxenus, turns out v2.2.2 and v2.2.3 (Android) fixed the rendering issue, so I just updated my code in Github so it’s the same for both OS’s. Thanks!

I tried every combination for the settings page but couldn’t get it to take. I used:
“jsgs350” “my-aeon-home-energy-monitor-no-battery” “master” but didn’t work didn’t use quotes in the IDE.

Hi @joelw135, sorry I forgot to include the Github repo settings. Here you go:

Owner: constjs
Name: jcdevhandlers
Branch: master


Thanks that did it, and the line changes fixed the IOS text.

1 Like

How do I add the battery information to my unite as I have no power plug availabe and must use the battery. Also I cannot get mine to calculate watts to K/W its reporting watts no problem but Im not seeing a change in cost. its at —

To add the battery tile AND to set parameter 12 to 1, please use this device handler:

I saw your PM about kWh, and while you can tweak parameter 12 to enable it while on batteries you’ll quickly drain them as well.

After you get the DH all set up in the IDE, be sure to Save and then Publish for yourself and change your device to use it. After that, go to the mobile app, go to your HEM, make sure the preferences are the way you want them (tap on the gear in the upper right corner), and then tap Done. Once the HEM device comes back up, scroll down and tap on Configure.

It will take some time for configuration settings to take effect because you’re on batteries, and the HEM’s minimum wake up interval is 4 minutes.

Hey @johnconstantelo I’m not sure if this is the right place to post but I (think) I have three issues:

  1. What’s the vertical box on the left.
  2. The minimum value never seems to be populated and so is stuck on null.
  3. What is the ‘–’ box for?

I have the ‘no battery’ device type.

1 Like

Thanks, that did the trick!

1 Like

Hi @Benji,

That’s supposed to be icon that says “Activity”, but ongoing text/tile rendering issues/differences between Android and iOS causes that to happen.

Tap on “Reset Minimum” and that should do it. That will also fill in the box replacing “–” with a message about what was last reset.

1 Like

Perfect, that did the trick! Thank you!

1 Like


I’d like to use my HEM v1 to monitor two 110v devices (washer, gas dryer) at the same time.

For some reason I can’t find the discussion regarding how to do that - I believe I have to use a different device driver than yours.

Can you point me in the correct direction, please?