Troubleshooting Aeon Labs Home Energy Meter v1

I think this is what you need?

2 Likes

^^^ The post right above this. Thanks @greg!

2 Likes

Withdrawn figured it out.

Just wanted to say thanks for this code! I had just installed the V1 version of this energy reader after getting a great deal ($11 bucks shipped), but was underimpressed with the reporting out of the box. Fortunately, Google brought me here, and after a few stumbles of installing the proper device handler, I got this working.

Thank you! I may explore adding code to the config to account for different kWh costs at different periods of the day, but this is a great start.

1 Like

Great Job. Bought this and thought for the longest time I had the latest (v2 or v5). Turns out it was V1 ($17 shipped from Buydig) and until Google brought me here, I was not happy at all with the device handlers. Very grateful for all the work!

2 Likes

Just as an update, it looks like the github repositories have moved here:
https://github.com/constjs/jcdevhandlers/tree/master/devicetypes/jscgs350

Hi,

First, thanks to everyone who has contributed to this topic–and especially @johnconstantelo for developing and maintaining his HEM device handler.

I’m a noob to Smartthings and Aeon’s HEM. I have some coding and IT skills.

I recently purchases an Aeon HEM hardware V1 and Smarthings Hub V2 in order to start monitoring our household energy use.

I have read through this thread and tried to cull the important setup points; however, this still isn’t working for me. After successfully setting up my Smartthings Hub V2, here is what I’ve done so far:

  1. Installed the HEM V1 clamps onto the two leads going into the main circuit breaker in my breaker box. I believe I did this correctly.
  2. I am using the USB AC adapter to power my HEM V1. It wasn’t clear whether it is also useful/recommended to include batteries (I’ve left them out for now).
  3. I paired the HEM V1 Z-Wave to the Smartthings Hub through the following process (which I’ve done a number of times now):
    -Exclude (if already paired, light on HEM V1 solid red)
    -Reset both devices (I always reset the HEM V1 and sometimes I reset the Smartthings Hub)
    -Pair HEM V1 again with black button under battery cover and the Smartthings app
  4. I created a Device Handler in the Smartthings IDE using @johnconstantelo’s code, I saved and published it ‘for me’. https://raw.githubusercontent.com/constjs/jcdevhandlers/master/devicetypes/jscgs350/my-aeon-home-energy-monitor-no-battery.src/my-aeon-home-energy-monitor-no-battery.groovy
  5. I edited my HEM Device to use this new Device Handler.

After this didn’t work, I continued to scour this thread and found an update to the HEM V1 firmware (3.67) posted here. I downloaded this and used the USB cable that came with my HEM V1 to perform the update. I used the ‘two phase’ driver, assuming this is really referring to the number of leads on my HEM. That update didn’t seem to help and I ended up reverting to an earlier version (3.61) of that driver that I found here, I’ve also tried version 3.64 too.

If I view the event log, I can sometimes see that there are periodic ‘unhandled event SensorMutlilevelReport’ that at least makes me think that the HEM is trying to communicate.

I can also see that when I press the ‘configure button’ on the device handler UI, I get the following error:

I appreciate any thoughts and guidance on next steps here.

Here are some questions:
Am I missing a step or not doing a step correctly?
What is the best driver to be using for Aeon HEM hardware V1?

Any other tips/suggestions to help me get unstuck are greatly appreciated!

It doesn’t look like you’ve missed any steps, so what I’d ask you to try is to go into the device Preferences (tap on the gear icon) and reenter the default settings. Once you do that, tap on Done and it will cycle through the configuration process. Watch your live logging again to see if that error comes back.

There really isn’t a “best” DTH because it’s all up to how you like to see the device in the app. Some are simple, and some are like mine. The basis for all of them is usually ST’s original that’s been tweaked a lot over the last 2 to 3 years.

Try going through your preferences and let us know what happens.

Hi @ch333,

The DTH’s for the HEM have been there for some time, as well as most of my other DTH’s used by the community. I finally got around to cleaning up my old repo and move the last of the stragglers over.

1 Like

Thanks @johnconstantelo!

I went into device Preferences and entered the default settings. The errors are gone now. I no longer get the ‘unhandled event’ messages either. One minor thing is that even though I press ‘Done’ in device Preferences only once, it seems to print out the debug messages twice in the log.

I’m still not getting a read on my energy use though. Any other thoughts on things I should try?

On my question about best ‘driver’–I really meant to ask which firmware is best. Which version of the firmware would you recommend?

Thanks!

Yeah, that’s a platform issue instead of a DTH problem. It’s frustrating because that should not be happening, but it won’t hurt anything.

If you’re still not getting anything, then remove the “//” on lines 178 and 184 in the code you’re using and watch live logging to see what the device is sending. You should see something like this:

Ah, I understand now. I recommend the latest because it does resolve wildly crazy numbers that can show up at times.

Thanks again! This was helpful. I can see the messages coming in now. Here is an example:

7:47:24 PM: debug Parse received zw device: 13, command: 3202, payload: 21 74 00 00 00 00 00 00 00 00 00 00
7:47:09 PM: debug zwaveEvent received MeterReport(meterType: 33, meterValue: [0, 0, 0, 0], precision: 3, scale: 2, scaledMeterValue: 0.000, size: 4)
7:47:09 PM: debug Parse received zw device: 13, command: 3202, payload: 21 74 00 00 00 00 00 00 00 00 00 00
7:47:02 PM: debug zwaveEvent received MeterReport(meterType: 33, meterValue: [0, 0, 0, 0], precision: 3, scale: 0, scaledMeterValue: 0.000, size: 4)
7:47:02 PM: debug Parse received zw device: 13, command: 3202, payload: 21 64 00 00 00 00 00 3C 00 00 00 00
7:46:54 PM: debug zwaveEvent received MeterReport(meterType: 33, meterValue: [0, 0, 0, 0], precision: 3, scale: 2, scaledMeterValue: 0.000, size: 4)
7:46:54 PM: debug Parse received zw device: 13, command: 3202, payload: 21 74 00 00 00 00 00 00 00 00 00 00

The log messages were coming in once a minute and so I found the ReportType parameter in the device Preferences and set it to 0 and began receiving more messages. So it looks like my Device Handler is working properly then.

I see the payload is zeros, so now I just need to figure out why it’s not getting a reading.

Is the most recent version of the firmware 3.67? I’m having a hard time tracking it down for some reason on Aeon’s support site.

Thanks!

Yup, that’s most current version. You’ll find it easier here:

http://wiki.micasaverde.com/index.php/Aeon_HomeEnergyMonitor

Thanks again for all the help!

It looks like at this point my problem has to be the initial installation step–the step I was initially the most confident in. I opened my breaker box again today to check everything. I’m pretty sure I have my HEM clamps installed in the correct place: one around each of the two large lines leading into the main 200A breaker.

The instructions that came with my HEM hardware V1 did not really discuss whether the clamps themselves needed to be oriented in a specific way. After reviewing the manuals for Aeon’s two most recent HEMs (here and here), it looks like the clamps may need to be oriented in a specific way (e.g., K->L, L->K). I’m wondering if anyone else who has there HEM V1 working had to do this?

Any other tips on things to check are appreciated.

I’m thinking though that even if I had the clamps backwards, I should probably still be getting some reading–does that make sense?

Thanks!

I finally got my HEM hardware V1 working today. I thought I would briefly document here (for posterity) what worked for me–in case this is of help to others in the future.

After checking and re-checking my HEM hardware V1 clamps, I decided there must be something wrong with the clamps or something wrong with the hardware that reads the signal from the clamps. So I contacted the place I purchased my HEM V1 from and obtained a replacement.

I setup the new replacement HEM V1 the exact same way that I had setup the old one. I did my best to follow the guidance here on the orientation of the clamps (e.g., K->L, L->K)–it’s not entirely clear to me whether this matters but I followed it as best as I could ensuring they were oriented in opposite directions. This time when I turned it all back on it worked!

I had upgraded the firmware to version 3.67, which as I understand it is the most recent. Unfortunately, all of the data was reflecting very high readings so I decided to downgrade to firmware version 3.64 and that worked for me–after the downgrade the data seems reasonable.

Thanks again to @johnconstantelo for writing and maintaining this ST device handler!

1 Like

I’m having the exact same problem as you with the Aeon Home Energy Meter v1. Can you tell me if you got yours working, and if so, what was the solution?

Thanks!

Hi @PlanetUSA,

By “having the exact same problem as you” what exactly do you mean? Can you elaborate?

In the end, my main problem appeared to be with a faulty HEMv1. I returned it and the replacement I received worked.

I’ve added this DTH and tried with two HEMv1 but it never shows up in “Add a Thing”. Ideas? The HEM is blinking steady on/off red.

have you tried first doing exclusion?

You go to z-wave utilities.
Start exclusion process, tap the button behind the battery cover.
once you get confirmation device is excluded you start ‘add a thing’ and tap the same button behind battery cover.

Yes, I have tried exclusion and followed your process. I don’t get any confirmation that it was excluded…would I expect to see that in Live Logging?