Troubleshooting Aeon Labs Home Energy Meter v1

@CAL7

I’m not sure if you know how to do this. If so, just ignore.
Here is a link to instructions for doing an exclude as we’re mentioning…

In this case, if the blink doesn’t change from slow to fast after pressing the little black button, I’m wondering if we’re dealing with different devices, because, while in ‘waiting to pair’ mode, mine blink slow, and then, when I press the little black button, they blink fast briefly until paired.

Agree with @johnconstantelo though, if it’s still not working after that, restart the hub too.

By the way, @johnconstantelo, I just haven’t been able to get to testing the HEM on the mains today (been sick for a few days and just took some time to chill out with the NFL and a pillow all day long). So, I will do it tomorrow and get back in here.

EDIT: @CAL7

[quote=“CAL7, post:35, topic:30962, full:true”]
…I’m not sure if I have v1 or v2. It’s labeled as Model DSB09104-ZWUS. [/quote]

I just checked mine and they are the same model number as yours here. So, we’re both working with v1.

No worries! Our weather here in the Carolinas has been great, so we’ve been outside quite a bit. Get well soon!

Paired!

Thanks for all the help. The ST General Exclusion did the trick.

One thing that seemed to matter was giving the black button a quick click. I think I might have been holding it a ms too long.

@johnconstantelo
Thanks.

@CAL7 Yep. I know exactly what you mean. Not only that, if you were to click it for a shorter period than you did, it may not have worked either. I found that there is a sweet-spot, and before I realized it, I was pressing it either too long or too short. lol

I finally connected the transmitter to the AC mains (BTW, it helps to connect the lines to the transmitter - I was moments from posting that no data was flowing to the app when I remembered that last step.)

Three questions: 1) the configure button doesn’t respond. Do I need it? 2) just curious… apparently my idle house draws 365 watts. Is that typical for today’s always-on, stand-by home? 3) How accurate are these monitors?

@seminarians @johnconstantelo Thanks again for your help (and the code).

  1. Configure doesn’t seem to do anything for me either
  2. That is lower than mine at idle
  3. I’m looking forward to comparing the reports with my electricity bill

Also, for what its worth I’m still not seeing a minimum value and I’m having trouble with one tile - see below

@CAL7

  1. It’s just supposed to send config data from the ST system to the device and may not ever let you know whether it worked or not, visually.

  2. I don’t know the idle draw of houses, but even if you have everything that you can think of ‘off’, yes, it definitely draws power, because there is always a light on somewhere on some gadget or appliance…many of them probably, and combined, they add up. However…

  3. this device is not accurate enough for us to use to really track usage. That’s why it’s so cheap, and that’s why they came out with a new version which uses different methods to track power usage. I really only bought the v1 models because they can be used to tell me whether or not something is on, and are cheap.

Also, it’s not a big deal, but I’m assuming you meant, @sgnihttrams in your last response (I don’t even see a user named ‘seminarians’ on the forum). No?

No worries @CAL7.

The configure tile button won’t do anything except send configuration parameters to the device to change how it reports. In this case, every 15 seconds (there are other things too, but that’s the most important). If you look at the code (towards the end), you’ll see what it does. Nothing happens in the app to let you know it did anything when you tap on it.

My idle is roughly in that range, but I’ve seen lower. All depends upon what you have left plugged in I guess. Over the holidays I may experiment and unplug everything to see what I draw, and then I’ll turn everything on and see what happens.

With regards to accuracy, I have nothing to compare to, but I’ll compare to my bill and reset energy data as close to the time when the electric company does their (if I can find that out)

I bought one of these about a month ago and haven’t ventured to hook it up yet. Reading the thread has got me motivated though :smile:.

How difficult is it to hook up powered to a breaker box?

Hi @Jkimrey, it’s really quite easy as long as you plan well and do it safely with the main power off. If I were you, just open the panel up and check to make sure you have plenty of room for the clamps, and how to route the cables out to the device.

Good idea. Will do that as a start. :smile:

@johnconstantelo
Well, I managed to get out to the breaker box to do this today, but discovered that it won’t be possible until I get some help from the power company (the city).

The problem is that, although I can get into the breaker box in order to recover when circuit trips, etc, the compartment where I’d need to get to in order to access the mains is locked. :confused:

So, I called and left a msg and will hopefully be able to get back to this in the next day or so…

Was offline last week, sorry for the delayed reply! :frowning:

I certainly can’t take credit for the code, as 99% of it is from Barry (https://github.com/SANdood/Aeon-HEM-v2/blob/master/Aeon%20HEMv2.groovy). I only moved around some bits here and there. :wink:

The modified code I have posted is for the HEMv1, although the file naming is a bit confusing as it includes ‘v2’ in the name from the original author. In the second line of code:

* SmartThings Device Type for Aeon Home Energy Monitor v1 (HEM v1)

@sgnihttrams I have replied to your post in the other thread. Sorry I couldn’t be more helpful.

1 Like

Wow, I’ve never heard of that situation before. Your electric company must really not want their customers getting injured, or they have something in there they don’t want messed with.

@johnconstantelo

Indeed.
Well, they came out to meet with me and take a look today, and wow…it’s worse than I thought…

Not only was it locked (as you’re thinking, they don’t want us hurt, but also don’t want anyone messing with their special metering device that they monitor it with from their homebase), but it’s also built in such a way that using the HEM won’t even be possible without some serious modifications.

First, the mains and the breakers are in completely separate compartments, and there are no cables running between the two. Rather, in this setup, they are using some other kind of mechanism for the power to travel from the mains, through their metering device and then into the breaker compartment…a mechanism that doesn’t lend itself to being able to connect the HEM clamps around anything.

Then, in order to even get into the mains compartment again (if I do decide to do the following), I will need to call them and schedule an appointment for them to come out again like they did today in order for them to unlock it.

Then, I will need to have somebody modify the mains compartment to allow the cables of the HEM to pass through the box to the outside where I would mount it on the side of the house or whatever, because it is sealed between the mains and the breakers.

Then, I will need to modify the breaker box…

  1. install new, separate breaker for the wires I will need if I want to power the HEM with AC instead of battery
  2. Pop out hole in breaker box for those wires to pass outside
  3. Seal said hole with appropriate fitting and some caulking or whatever

So, I don’t know if I’m even going to do all of that, but at least I now have a good handle on what would actually be needed if I do decide to go that route.

However, they are working on and will soon be implementing and releasing to us a customer portal of some sort that will allow customers to log in and see our energy usage online. Within that system, it will also be possible to configure alert notifications that will go to an app on mobile devices and sms text messaging alerts which I would then be able to get into ST via IFTTT.

It’s not completely horrible, but wow.
I guess I can see their side of things…If I were them, I’d much prefer my customers not getting zapped, and I would feel pretty good about having presented a way for them to be able to track their own usage and get alerts like this.

Since implementation of this new portal is in the near-term, I guess I will just hold off for now, and see what it’s like. If it works for my needs, fine.

The only problem though is that, unless I actually pull the trigger and do the work necessary to install my own energy meter, I will be at the mercy of theirs, and won’t have a ‘second opinion’ on usage.

That said, given the low confidence we now have in the v1 HEM’s metering/tracking abilities, I guess that wouldn’t be something I’d trust up against their metering system anyway.

So, if I ever do decide to do the modifications, it won’t be until I have a v2 HEM or something else that is more trustworthy for actually metering/measuring real usage data anyway.

My HEM is reporting out great, maybe too great. My ST Activity Feed gets a report roughly every 6 seconds. Is it possible to select on/off for the feed?

@CAL7, yes you can adjust how often it sends data, as well as thresholds. If you look at the code, scroll down to the bottom to the Configure section. That’s where you tweak reporting settings, specifically parameters 3, 4 and 8 (and 111 depending on other settings).

If you are using my device type, it reports every 15 seconds at least (parameter 3 set to 0, and parameter 111 set to 15), but if you change these lines:

zwave.configurationV1.configurationSet(parameterNumber: 3, size: 1, scaledConfigurationValue: 1).format(), zwave.configurationV1.configurationSet(parameterNumber: 4, size: 2, scaledConfigurationValue: 25).format(), zwave.configurationV1.configurationSet(parameterNumber: 8, size: 1, scaledConfigurationValue: 10).format(),

The HEM will only send data (paramter 3 set to 1) when a 25 watt difference has been detected (parameter 4), or there was at least a 10% change (parameter 8).

Hope that helps.

Brilliant! Thank you.

1 Like

@CAL7, no worries. Make sure to tap on the Configure tile after you save and publish the changes for yourself.

Thanks to everybody for the great thread. It has helped me overcome several problems, but I am stuck. The screenshots below seem to show I have a zwave connection but no data is coming through. I have two installed and am getting the same on both. Any direction would be appreciated! Thanks