Troubleshooting Aeon Labs Home Energy Meter v1

I had this same problem at first. I unpaired and re paired a few times and then it magically worked.

Thanks Greg. I will try that this weekend and post an update.

@johnconstantelo I am using your Aeon Home Energy Monitor v3 device type for my HEM v1 and my values are showing much higher than expected. Current watts is showing 6 digits. (204768).
No errors, just values are high. Any ideas. I think if I divided by 100 it would be fine.

Hi @e_banks, I’ve had that happen many times for the Max value. I don’t believe it’s an issue with the device type because it’s fine all other times. I remember a discussion a long way back about the v1 sending wild numbers every so often. The latest firmware for the v1 may resolve this issue, but I haven’t updated mine yet to confirm. Seeing your reply has got me motivated to try. I know you’ll have to reinclude the device back to the hub after firmware update.

I occasionally get crazy numbers in the millions. Curious if you have any success with the firmware upgrade.

I will give it a try. Do the clamps on the incoming power need to be specifically positioned or oriented?

No they don’t, just as long as they’re properly clamped around each feed.

Aeon’s website has v3.64 available for download, but I also found v3.67 on the Vera site.

Hi @e_banks,

I just updated my firmware to this one:

http://wiki.micasaverde.com/index.php/Aeon_HomeEnergyMonitor

Specifically: US version: HEM367

Afterwards I reincluded it back to my hub without a problem!

1 Like

I updated to the 3.67 but now nothing works. It sees the HEM but no reading.
I am going to walk back through this again.

Steps:

  1. update to 3.67
  2. exclude
  3. connect with app and push small black button on hem
  4. change device type to your code.

??

@e_banks,

Make sure the red LED is slowly flashing, and once the join process starts it will rapidly blink and turn solid red.

When it joins it should use my device type before attempting to use the default.

Once it joins, make sure to tap on the Configure tile. Also, are you using USB or batteries for power?

@johnconstantelo
It is back to reading again. It did go to a different device type but I switched.
Once I hit configure it started reading. I am using USB.
Below are my readings.

energy: 166.777 kWh
power: 877617 W
energyDisp: 166.78 kWh
energyOne: Energy Data (kWh/Cost) Reset On: 2016-01-01 8:32 PM
energyTwo: Cost $26.68
powerDisp: 877617w
powerOne:
powerTwo: 1411415w on 2016-01-01 8:42 PM

Hi All,
Got a Aeon HEM v1 a few weeks ago, and finally getting around to trying to integrate it with PlotWatt and get a better SmartApp for it. I’ve tried both @johnconstantelo 's app and Barry Burke’s. With both of those apps, when I try to create a new app from code, I get the following error:

No signature of method: script1451702660603118719504.metadata() is applicable for argument types: (script1451702660603118719504$_run_closure1) values: [script1451702660603118719504$_run_closure1@1b057121] Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure)

Any tips?

@Nate_Sharpe, This is code for a device type, not a SmartApp.

@e_banks, how did your readings get so high soon after adding the device back you the hub? I’d reset everything because everything should have started from zero.

@johnconstantelo
This is what it looks like after reset. Then numbers are still huge and increase rapidly.

energy: 0.000 kWh
power: -1984137 W
energyDisp: 0.00 kWh
energyOne: Energy Data (kWh/Cost) Reset On: 2016-01-01 10:10 PM
energyTwo: Cost $0.00
powerDisp: -1984137w
powerOne: -2040301w on 2016-01-01 10:10 PM
powerTwo:

Hi @e_banks, wow that’s not right at all. I’ve never seen anything like that before. I’m sure the device type isn’t the root cause because I’d be seeing the same thing. What do the energy and power numbers look like when you use ST’s default device type (Aeon Home Energy Meter)?

@johnconstantelo
This is what I got after changeing device types and resetting numbers then waited about 1 minute.
Name Aeon Energy Meter
Label Aeon Energy Meter
Type Aeon Home Energy Meter
Version Published
Status ACTIVE
Hub Home Hub
Last Activity At 2016-01-01 10:45 PM EST
Date Created 2016-01-01 8:21 PM EST
Last Updated 2016-01-01 10:43 PM EST
Data No data found for device
Current States

energy: 19.403 kWh
power: 160721 W

@e_banks,

Definitely something is wrong. I’d make sure you have each clamp on a separate feed wire in the box, the connections are all solid and tight, and that clamps are closed completely and not catching on something.

You could try removing and readding it, but I personally don’t think that will help because this was happening before the firmware update. Out of curiosity,when you ran the update EXE, did the status bar stay green all the way to 100%, and did it only take a minute or less?

If all else fails, I’d contact Aeon for help.

@johnconstantelo

The update took less than a minute and I waited until it said 100%.
I will check connections on wires in morning.

Thanks for your help.

1 Like

@johnconstantelo
Found the answer to my problem on another posting.

Aeon HEM v1/v2 Firmware 3.64 Numbers are Off?

I added this line to the config function:
zwave.configurationV1.configurationSet(parameterNumber: 255, size: 4, scaledConfigurationValue: 1).format(),

This reset to factory default when you hit the configure button.
Now my numbers are good.

Thanks for your help.