Aeon Labs Energy Meter clamps

@sgnihttrams, buttons are available in the trigger or conditional trigger section.
The buttons will fire when the connected appliance wattage transitions below the what you have configured.
The switch is on if either alliance is on, and off when both are off.

1 Like

So, perhaps, for my kitchen cooking odors rule, I will use the switch to trigger turning the HVAC fan on, and then use the buttons to trigger turning it back off after a delay (if that’s possible with those buttons).

Obviously, when I get around to setting up my other v1 HEM, I will use it pretty much like you use it for my washer/dryer laundry tasks.

Thanks! :slight_smile:

1 Like

Yea, that should work as expected.

One more question about these things…

If I want to maximize the usefulness of a v1 HEM (staying in the same use case vein as we just discussed to get me going), would it be OK to put a clamp around more than one appliance’s power cord in order to, let’s say, monitor two or three or more appliances?

I know that it would only tell me that some device in the set is on, and I wouldn’t be able to know which one.
I’m just thinking, if what really matters in this use case (my kitchen cooking odors rule) is knowing that ‘something’ is on, it shouldn’t matter which one, right?

no reason not to, but it might be better, (read easier) to move the clamp over to the breaker that runs your kitchen.
Running multiple split cords through one clamp is sure going to look ugly, if it’s even physically possible…

Ya, my breaker box is a bit of a kludge, and requires the power company to come out to unlock it in order to even get into where the mains are (TLDR)…

So, although I could do what you suggested, if there’s another way to do it without getting into all of that, I’m going to hold off on that until or unless it becomes absolutely necessary (like when I eventually get around to putting one out there to monitor the whole house).

Fixed the problem in rendering on the following lines. All I had to do was on the label line remove the 'n" in front of Watts and Energy and the line renders properly.
standardTile(“resetmaxmin”, “”, width: 3, height: 2, inactiveLabel: false, decoration: “flat”) {
state “default”, label:‘Reset\nWatts’, action:“resetmaxmin”, icon:“st.secondary.refresh-icon”
standardTile(“reset”, “”, width: 3, height: 2, inactiveLabel: false, decoration: “flat”) {
state “default”, label:‘Reset\nEnergy’, action:“reset”, icon:“st.secondary.refresh-icon”

Good find @joelw135. I made the change to my code as well, and github has been updated. It’s too bad we keep finding differences in how ST’s app looks on iOS and Android, but I suppose trying to keep things the same across two very different os’s is a bit challenging.

1 Like

I am still trying to find a way to fix ST’s problem with the Power Outlet not showing power in IOS, so far no luck.

I know this is a bit old but I thought I would share what I did.

I installed an outlet and extra breaker inside my electrical box. I live in an apartment so I didn’t want to punch a hole on sides of the box. I just got two feet of 12AWG conduit from Lowe’s ($1.60 I think), a 20A breaker (under $6), a “slimline” plastic wall box (under $2), an outlet ($1.50, tamper-proof), and a cover. I then wrapped the outlet and everything in electrical tape.

Here it is from the outside (the solo breaker at the bottom is the power meter breaker).

And from the inside. My hub is about 20 feet from the breaker box and I haven’t had any range issues in the past week since I installed it.

1 Like

[quote=“jbv, post:280, topic:359, full:true”]
I know this is a bit old but I thought I would share what I did.

I installed an outlet and extra breaker inside my electrical box…[/quote]

This sounds cool. :slight_smile:

For those of us with whatever it is that’s preventing my brain from fully getting it, would you be willing to add words and arrows to the pics…or maybe do a quick video (with audio) to point things out?

hey guys, having major issues

I press the button and it slow flashes continuously, i then go to add
device on my smartthings and then the meter goes solid but nothing comes
up in ST. Each time i press the action button now, it fast flashes for 1
second then goes solid, so it would make me think its paired but i
didnt get the option to add the device in the ST app (also cant find a
device created anywhere).

I have to exclude the device to get it to slow flash constantly again, then have tried the inclusion process probably 40 times.

1./ Sitting right next to the hub
2./ Tried with and without batteries
3./ Tried on AC only
4./ tried with clamps on and with clamps unplugged

Any help would be greatly appreciated.

Many thanks

Any chance you could walk me through getting this set up. So far, I have never been able to make anything involving code work. Would love to see a graph from my hem v1 data.

And the requested diagram:

1 Like


Is this your most current DTH for using the Aeon-HEM v1 as a laundry monitor? I have successfully created a custom DTH and assigned it to my Aeon-HEM v1. It properly reports the overall laundry state in the MultiAttribute tile, and the per device power usage, however the state of the Washer and Dryer tiles never seems to change. Any idea of what I am doing wrong?

For testing, I am simply changing the threshold in the preferences section for the washer and dryer, and then waiting for an update to occur.



I don’t know, but here is the one I’m currently using.


I think I know what the delio is…
The clamps must be placed around the hot or neutral lead, if you place the clamp around both the net measurement will be 0 (since the current through the hot and neutral will cancel each other out from the meters perspective)

1 Like

That would be it…
You need one clamp around each pole of the circuit. Neutral won’t work though as far as I know, but I don’t remember if you can run a single clamp.

The above DTH specifically configures the device to read each clamp independently (rather then summing as you would need when measuring each leg at your panel)

Yep, I understand the need to only put the CT around one leg of the circuit (I am an electrical engineer :wink:.) So that’s not the issue. It appears to be an issue with how the iOS version of the ST App is trying to render the two valueTiles for the Washer and Dryer State. Otherwise, the latest DTH you pointed me to appears to be working well. I’ll try tweaking the DTH to make it suit my needs.