Aeon Labs Smart Energy Monitor Meter

hubv2

(Raoul Banks) #1

Has anyone worked out the compatibility problems with the S/T hub? I have been looking for a smart app that will allow the device to be monitored frequently, whenever the current changes. Is the newer version (with voltage input) work any better…or at all?


#2

@RBanks I guess I’m a little confused about that statement. What compatibility problems? I have the v1 version of the meter, and it works perfectly. You can either have it report on a time frame, or based on a change in wattage (watts or %) using a custom device handler like the one I modified. I’ve also been using ST’s Energy Alerts SmartApp for notifications with this device without any problems.

Can you clarify what you mean?


(Raoul Banks) #3

Sure John,
My SmartThings Hub Connects with the device, but reads only Current Power (Watts/Kw) on my Android Tablet…and then somewhat haphazardly (changing trip range doesn’t appear to increase the poling frequency. At one time it used to return energy consumption (Kw-Hr) but that stopped weeks ago. I have diddled with any app that looks promising, but no joy. Does the new version of the energy meter work better?


Aeon-labs-smart-energy-monitor-meter V1
#4

Hi @RBanks,

Try using my device handler:

https://raw.githubusercontent.com/constjs/jcdevhandlers/master/devicetypes/jscgs350/my-aeon-home-energy-monitor.src/my-aeon-home-energy-monitor.groovy


(Raoul Banks) #5

Well John,

I was hoping to be amazed…and you sure got most of it. The major remaining problem is that it updates power (current usage) often enough, but total energy only once so far. Since I want to use this to track energy consumed (Kw-Hr) in a rental unit, I need it update often. I still have no smart-app installed, is there one that will force poling (?) energy totals on a specified schedule.

Thanks in advance,

                                                Raoul

#6

Hi @RBanks,

Ok,progress!

Let’s try tweaking device preferences.

What if you changed ReportType to 0 (time based reporting), and then for the last 2 parameters dependent upon ReportType = 0, set the time to how ever many seconds you like. Right now the default is to reports watts every 15 seconds and kWh every minute.

I bet that does what you want, and you don’t a smartapp.

Do you know how to access the device Preferences in the app?


(Ricky) #7

Hi John,

I created a device handler from your code above, then I removed the batteries, USB, reconnect it, added it to the app but no data has populated in 1 hour. Help please.
Thanks,


#8

Did this start working for you?


(Ricky) #9

It took like 15 minutes but it’s all working now, Thanks John


(Ricky) #10

I meant another 15 over the hour


(JIm) #11

I installed this DTH, connected the Aeon sensor.

Even tho the batteries are brand new, it reports that the batteries are dead.

Should there be separate readings for each leg?


(Glenn Canavan) #12

On mine, there is only one reading, which is the combined value of the two legs.


#13

Unplug the HEM from USB power and battery reporting will happen eventually.

No. You need a custom DTH to see readings for each leg.


(Glenn Canavan) #14

Try checking out this thread Aeon Home Energy Meter v1 -- Read Clamps Separately


(Joel W) #15

@johnconstantelo I updated the DTH today for IOS and the text is again to small to read. I tried going into config and click done no luck.


#16

Ah crap… Which tiles, can you post a screenshot?


(Joel W) #17


#18

Hi @joelw135, I just updated Github again. Text should render again to a larger size. I’ll put the changes back after the next iOS release since supposedly it should be resolved by then.


(Joel W) #19

Thank you John works perfectly now.


(Emerson Vier) #20

Hi Why I see on corner yellow ! ?