Trouble with Alexa

A few things going on:

  1. I can see all of my smartthings devices in Alexa.
  2. I can’t see an Alexa or Echo app in smartthings
  3. I have an echo and an echo dot. Not sure if I have one or both linked.
  4. If I ask Alexa to “turn on office” she says “ok” but the light does not come on. I have full control of the light (Philips Hue) from Smartthings.

Any thoughts?

Did you run Alexa discovery, either by voice command or the Alexa mobile app?

If that’s true then there’s no way the Alexa service should be authorized to even know about your ST devices. You not only need to have the “Amazon Echo” smart app installed, you need to run it and explicitly authorize Alexa to access the devices you want it to control.

Linked…in what way?

If you’re correct about not having the Amazon Echo smart app or ever using it to authorize Alexa to access your ST account then you need to contact ST support post haste and figure out what’s going on.

I’m going to assume you also have a hue hub and that is what your bulbs are connected to?

If yes, you need to go to the Amazon echo mobile app, tap on smart home, tap on skills, find smart things and tap on it. Follow the directions.

When done, go into the smart things app, tap on smart apps, find the Amazon Alexa smarts and open it.

Select the devices you want Alexa to see. DO NOT select any devices that are also connected to another hub, like your hue bulbs… Unless those are connected to the st hub. If you select something here that is also connected directly to another hub, and that hub is connected to Alexa, the device will show up in the Alexa mobile app multiple times causing you all kinds of trouble.

Now, tell Alexa to discover your devices.

When that is done, tell her to turn off your light.

I’ll contact support. Was just hoping there was some way for me to force install the Echo app on ST.

No Hue hub. I just use the smart things lighting app. Seems to do everything I need. I only have a few bulbs.

Now, tell Alexa to discover your devices.

When that is done, tell her to turn off your light.

Alexa says that she is turning on or off the bulb. No turning on or off happens.

did you go into the Amazon Echo mobile app and complete the integration with SmartThings?

If you’ve never gone through the steps required to expose your ST devices to Alexa…namely, installing the Echo smart app in ST and then authorizing access to your devices…why did you initiate device discovery on your Echo?

How do I install the Echo app on SmartThings? I can’t find it listed under SmartApps.

I’m having the exact same issue. When I go to the SmartThings skill in the Alexa app, it gives me the option to disable, but not Discover as shown above. I also don’t have the Echo SmartApp showing in my SmartThings app. The only network devices I can see are my WiFi devices, no Z-Wave.

OK, making progress. I ended up uninstalling the SmartThings app from my phone and doing a full reset on the hub. Then reinstalled.

This was prompted by the Alexa SmartApp showing up in my on-line profile but not on my device.

Now I’m working on trying to get the Schlage lock reconnected as I didn’t have the forethought to kick it off the hub prior to resetting it.

I now see the outlets and other things I have connected to the hub, and as mentioned above they showed up in duplicate in the Alexa app since I had already connected them via wifi. I’ve now disabled those so I’m only showing one of each device.

One day…