OSRAM bulb is in SmartThings but Echo is not detecting it


(Cameron Murdaugh) #1

Is there something I need to do special (like change device type) to get echo to see the devices?


#2

Using the Amazon Echo SmartApps you need to add it to "My Switches"and ask Alexa to discover new devices

This will make Alexa find you new bulb


(Cameron Murdaugh) #3

Wait that is confusing, why would the amazon echo app know about the light bulb if alexa can’t discover it. Did you mean SmartThings smartapp? Where is this My Switches section?


(Cameron Murdaugh) #4

The problem appears to be that i have to disable the smartthings thing in alexa and then re-add, then i can authorize the devices. Is there really no way to authorize new devices added?


#5

See step 10 in the set up FAQ. Anytime you add a new device you have to individually authorize it from SmartThings to echo before a echo will be able to discover it. You can do it just for the individual new devices, you don’t have to remove SmartThings altogether. Just follow the instructions in the FAQ.


(Kevin) #6

In the SmartApps section of the SmartThings app, open your Alexa smartapp. In there you have to check off all the devices you want to ‘export’ to alexa. Then it will tell you to then have alexa ‘discover new devices’. You can either do that with a voice command or the alexa app in the smart home section.

So its a 2 app process really.