Alexa not working with ST


(James ) #1

Alexa did not discover any devices from ST


(Mark) #2

Did you authorize Alexa to see your devices from the smartapp in the SmartThings mobile app, then tell your Alexa device to discover?


(James ) #3

Yes, Alexa is authorized


#4

Why don’t you provide exact details of what you did do to try and get it working so that people can better assist you.


(James ) #5

Ok i have three GE switches i am able to control in ST app my ST hub is wired. I have reset Alexa, i disabled ST and re-enable allowing Alexa to be authorized.


#6

Validate this:

  1. You Enabled the SmartThings Skill inside Alexa

  2. You then opened the SmartThings Mobile App and went to Automation/SmartApps and opened Amazon Alexa? I would recommend not selecting the Authorize all inside here, but manually selecting which devices can be discovered:

  1. If you did both of these things, then you can discover in Alexa.

Note: Number 2 above automatically gets created in SmartThings as a SmartApp when you enabled the skill in Alexa.


(James ) #7

Yes, i enabled the ST skill inside Alexa, however when i go to ST mobile App, automation/ST the only thing i see is + add s Smartapp if i hit that a drop down list appears but i did not see Amazon Alexa


#8

How long ago did you enable the Skill in Alexa? Sometimes it takes a while to make it’s way over to SmartThings.


(James ) #9

I have been working on this on/off for two days but the last time disable and re-enable about 40min ago


#10

Are you a new ST customer and just created your account in the last few days then? Or have you been an ST customer for a while?

When you are in the SmartThings App, you see your GE devices fine listed inside Things, correct?


(James ) #11

About two mouths ago i buy the ST hub a z-wave outlet i setup a routine with no problem but was unable to see the outlet it in my dot at that time there was no need to use alexa

in the alexa app in settings i do see my fire stick FYI

my router has 4 wi-fi under the same network FYI


#12

Ok so do these things and validate:

  1. Goto the SmartThings Skill in Alexa and select Settings on it. It should show Linked in green

  1. When you enabled the Skill and you logged in, did it have a selection for your ST Location? Make sure there is only one Locarion name to choose from. If there are multiple choices to select from, stop and let me know. You can disable and re enable if you don’t remember.

  2. I’m going to have you login to IDE to see if Amazon Alexa exists there. I will give you instructions for this after you do 1 and 2 above.


(James ) #13

I went to skill settings in alexa and see the green linked i do not remember selection a location


#14

Ok skip that for now:

  1. Open a browser and goto https://account.smartthings.com
    (Login with same email / pw as your ST app

  2. Goto Locations (should only be one - if there are more, then stop (do not proceed) and tell me.

  3. Select Installed SmartApps

  4. Scroll down to Other. Do you see Amazon Alexa?


(James ) #15

i did not locate location i see profile, service, notice, personal info setting and security on the left side


#16

Something isn’t right. Show me a screenshot.

When you login to IDE you should be able to select under Developer Tools:

Location
Hubs
Devices
SmartApps
Device Handlers


#17

Click on the link I provided you above. What you are describing to me is you logging into the Samsung website, not the SmartThings website.


(James ) #18

ok there was nothing under location


#19

Open a ticket with Support.

Explain to them that you enabled the SmartThings Skill in Alexa, but the Amazon Alexa SmartApp doesn’t show up in the SmartThings Classic app. Something wrong with your account maybe.


(James ) #20

ok thank you so much