Triggering GH routines using new device trigger issues?

I know this is technically not a SmartThings things problem but has anybody else tried using the device triggers in Google home? I am currently using a virtual switch to try to trigger a routine and it is either intermittent or doesn’t work at all. Is anybody else having this problem?

I set up a number of Google routines a few days ago and they seemed to work well, but with a little time delay.

Tonight after I read your post I went back and tested some of my Google routines and most of them failed to run. It seems like something has changed.

Something like….

My cabin location has a bunch of devices connected to the Tuya app. Tuya automations are lacking, so I use the SmartThings App with no ST hub to do more complex automations.

Many Tuya devices do not integrate with ST, so I write Tuya screens (tap and run automations) and they get integrated into ST. They are rock solid. The problem is that they are 1 way integrations. ST can control Tuya, but Tuya doesn’t update ST when someone operate something like a switch.

So, I am using the Tuya devices as triggers in “new” Google routines to update the ST virtual switches.

It worked good last week, but is not working today.

Yes, something is broken badly. I can run the routine manually but it fails to launch via the trigger 99% of the time. I was excited about this finally getting GH to announce things like if someone is at the front door.

I am see the same thing. I can manually trigger the routine using the play button in Google, but the automatic trigger didn’t work.

I just set up 2 Google test routines where both the starter (if) and action (then) devices were from ST and everything works as expected.

So my problem appears to be when the starter (if) devices are from the Tuya or myTS apps.

My IF and THEN are both from SmartThings and it fails to run almost every time.

So now the routine triggers fairly reliable mind you there is a bit of a delay but the announcement isn’t playing at all. It does if you manually run the routine but not of you toggle a switch/bulb/etc… Anyone else having this issue?

Yep same issue here. Switch/Light as starter doesn’t trigger the routine.
Starting the routine manually is working