TP-Link Tapo P400M outdoor plug has 2 outlets, but Smartthings only sees one (sort of), and struggles to pair after reset

OK, lots of things for this device. I’ll start with my main issue:

When my V2 hub (version 000.051.00002) pairs with this device either directly or as a Multi-Admin, it shows on the device overview as a single switch. If you toggle it on or off, one of the outlets on the device will toggle. The other outlet is unaffected.





I would expect the toggle at this level to affect both outlets. If you go into the deeper view for the device, it will show two outlets, and let you control each individually. Is there a way I can get the SST app to turn on/off both outlets via the single button on the overview?

It seems to be a SST issue. For example, if I add it via Matter and Google Home, both outlets will show, and if I then add SST as a Multi-Admin via GH, I’ll get both outlets (with the same issue as above). However, if I add it via SST, and then Multi-Admin Google Home, only one outlet will show in Google Home, presumably because SST is treating the device overview as one outlet instead of one device with 2 separate outlets. Something about burying the outlets in a sub-menu breaks something.

My other issue is related to the same device: When I took it out of the box, I was able to add it to SST via scanning the Matter QR. It still had the one-outlet-unless-in-menu issue, but it added no problem. I reset the device and tried to add it to SST again, and it never gets passed “Prepare your device”. Eventually, it will show “Something went wrong” and “Error code 05-300”. I can add it via the Tapo app and Google Home several times without issue, but SST only worked the first time. I tried

  • Rebooting the hub by power cycling
  • Clearing Smartthings Android app cache
  • Reinstalling and re-logging into the Smartthings Android app
  • Manually inputting the Matter code rather than scanning
  • Updating the device firmware via Tapo app

Nothing lets SST get through to the device. This seems like another problem with how Smartthings is handling Matter devices. Is there anything I can do to add a Matter device to SST after reset?

Edit: added screenshots

I wonder what options would be available in Settings for the device… when you tap the 3 dots and select Settings. Maybe you can look once you get it added back.

I believe you forgot to mention you removed the device from ST where you said you reset it? Can you clarify the steps you took? Login to the Advanced Web App to make sure the device has been removed.

Last item… reboot from the advanced web app as opposed to power cycling the hub.

Just adding some more observations: by locking the 2nd outlet behind the menu, it can’t be accessed by any routines or virtual switches. I investigated those options as workarounds, but nothing in Smartthings can see anything except the “single” device, which ATM only controls one outlet. This means that the 2nd outlet cannot be put into any routines, save for a timer mode accessible from the toggle view, itself.

Here’s what I see in the 3-dot menu:

For resetting the device, first I removed the device via app, then I held the power button for 10 seconds until the device made a click and started flashing red and green, alternating. Doing this made it possible to connect the device via other Matter controllers (Google Home, Tapo app), but for SST it would get stuck in “Prepare your device”. One quirk of the device is that the flashing colors are meant to indicate it is ready to pair, but in reality it sometimes is not, and has to be paired quickly after the reset process I described. Otherwise, Google Home, which pairs seemlessly otherwise, also would not find the device. This seems to indicate something related to device-pairing timeout that isn’t made clear by the device’s own lights.

I’ll try to reset again with this in mind and report back.

OK, some progress: using the “pairing timeout” theory I posted above, I realized that SST also suffers from the same issue Google Home does: the device indicates that it is ready to pair, but it is not. I was able to successfully add the device via SST as long as I did so within a few seconds of putting it into pairing mode.

However, other issues that I mentioned remain:

  • The device hides one on/off toggle behind a menu, which can’t be seen by anything else in SST or linked services like Google Home.
  • This means if I add the device via SST, and link (not Matter Multi-Admin, just regular cloud link) only one outlet shows in Google Home.
  • If I add it via Google Home, GH sees both outlets separately, and SST continues to hide one outlet.
  • If I add it via SST and Multi-Admin for GH, GH will see both outlets separately.
  • In fact, if I Multi-Admin through SST, and link SST via cloud, Google will see 3 devices: the “single” outlet that SST reads, as well as the separate outlets that Matter reads.

This effectively means that in order to get the full functionality of this device, and continue to use SST–>GH cloud integration (for my other devices like Zigbee stuff), it simply can’t be added via SST, it has to be added via GH and Multi-Admin’d.

However, this still does not solve the issue of SST hiding one outlet, it’s just a workaround using another service entirely (GH).

One thing I haven’t tried, because I don’t think it’s possible, is adding the device to Google Home and then cloud-linking it to show up in SST as 2 separate outlets (as Google reads the device). As far as I know Google Home only allows cloud linking for incoming devices, not outgoing devices. The Multi-Admin is a slight improvement, but it doesn’t fix the way that SST sees the device.

And in reality, SST is seeing the device as it should: a single device with 2 switches. The problem is that none of the other SST features are designed to handle such a device, so operating or automating the device is broken.

Since GH displays the device as 2 separate devices, another thing I tried was to Multi-Admin each one. However, SST understood the first one as it always does (1 device with 2 switches), and threw an error when it tried to additionally add the other outlet separately.

Actually, I tried to do it twice so that I could screenshot the error, and now GH flashes a toast message that says “Can’t set up device”, presumably because the software caught up and is trying to indicate that it’s already been linked (this is strange, though, since Multi-Admin should work with more than controllers, so it shouldn’t matter that it’s already sharing one).

This is typical of this sort of multi-component device in SmartThings. The dashboard tile only has the status and action for the ‘main’ component which is switch #1. The remaining switches are then implemented as additional components. It is purely a UI issue with the app.

There is an alternative approach where this sort of device is implemented using child devices rather than components, so effectively there would be one device for each switch. This has recently been retrofitted to the matter switch driver but the change hasn’t reached production yet. I think it might do so next Tuesday if all is well.

I personally don’t particularly like this approach but I seem to be in minority with this view.

I wouldn’t. An ‘all off’ command might have merit but an ‘all on’ sounds unwise. I do agree that the UI is inadequate though as it is rather arbitrary.

That doesn’t sound good. It could indeed be the multiple components confusing things. Obviously it shouldn’t but it wouldn’t be unprecedented, as you have noticed with the Google linked service.

OK, another discovery: it’s not exactly true that the 2nd outlet/switch is hidden from everything else. It is definitely hidden from 3rd-party services, which can only see the main/parent switch when importing/linking SST.

However, I’ve realized that it is possible to create a routine and target either/both the main and child devices. This means that I can solve one problem: pressing the main switch on/off toggle and having the other/child switch do the same. I can also control both switches via routines, generally. See these screenshots:


That is precisely why I dislike the ‘child device’ approach. SmartThings had it right to start with. It is just that the client apps do a poor job of presenting the device to users and some of the integrations to other services just don’t map the devices adequately.

There shouldn’t be any problem with automations though. Routines understand multi-component devices. Historically they have sometimes made a pigs ear of showing that they do, but they do. Ah, I see you have discovered that now.

Yea, I thought that I wasn’t able to access the child devices because they don’t show on the device-selection screen, but once you select the main device you can edit a routine and choose the child devices. In this way, I’ve created a device switch on the device overview (the “room” view) using a Virtual Switch and a routine:

Alright, some final thoughts:

  • It’s still finicky to add this particular device via SST app. The only way I could do so repeatedly was to
    • make sure that the device is removed from everywhere (SST, Google Home, Tapo, where ever it’s existed),
    • close the SST app,
    • clear the SST cache,
    • trigger the device pairing on the device,
    • and scan via SST within a few seconds. If the “Prepare your device” screen lasts longer than 10 seconds, it will fail. Try again, and if it doesn’t work you might need to dig deeper into caches, uninstalls, etc.
  • If you want to control the 2nd/child switch as its own tile, it needs to be a Virtual Switch with a routine that points to the child switch. It won’t show up in the device selection, but once you select the main switch you can edit it to target the child device.
  • If you want a third-party service to control the outlets separately, and don’t want to use Multi-Admin to add the device to another Matter controller, the Virtual Switch will still show up in cloud linking (I find that every time I make a change to SST and want it to show up in Google Home, I need to unlink and relink the services; reconnecting is not enough). This is at least true for me with my Google Home. This allows me to control each outlet with my voice, and also control each outlet via SST (which is useful if the internet, and thus the cloud, is down).


Hopefully this is useful to anyone facing similar challenges in the future! Thanks for coming to my talk. :grin:

Are you using “SST” as an abbreviation for SmartThings? Most posts in this forum just use “ST” for that, so I just wanted to be sure I understood. :thinking:

1 Like

Yes, for “Samsung Smartthings”. I’ve seen both, for example: SST WiFi Power Adapter Tip?