TP LINK Kasa - Bad Request. Please try again later

Changed my Kasa password which turned out to be a big mistake.

Actiontiles stopped accepting commands, showing error 500.

Tried to update the connection under linked services which did nothing.

Removed the TP Link Kasa linked service.

Tried to re-link and at the login page it gives the following error:

Bad Request. Please try again later. If issue persists, please contact TP-Link Kasa customer support for further instructions.

Have been trying to login for 24 hours now intermittently, same error.

Created brand new Smartthings account and Kasa account and attempted to link them, same error:

Bad Request. Please try again later. If issue persists, please contact TP-Link Kasa customer support for further instructions.

Is this just me or is it broken for everyone ?

Kasa support had no idea what I’m talking about asking me if my computer is connected to wifi

is this error before or after authentication?

The password change for Kasa never goes well for users.

You should report the issue to ST support also (if you haven’t already done so).

doubt I can suggest anything to assist. no pihole? try a different device with different OS… if using Android… try iOS. Again… doubt anything I come up with would have any effect. recommend ST support and raise it to a higher tier of support.

good luck!

Just reported to ST support. This is how it goes:

But the thing is, I also tried making brand new Kasa & ST accounts with a different email and tried linking them together and the same error came up…

The error comes up after i put in my email and password and click Authorize.

It comes up instantly like in a millisecond once i hit Authorize

got to follow up. in your first post you mentioned removing the tp-link integration. did you remove the one that shows disconnected in your screenshots or is that a listing after you attempted to link unsuccessfully?

oh! I do have one suggestion (to try) :slight_smile:

you can link your Kasa account in the Tapo app. login with same tp-link account used for Kasa. Once you link Kasa to Tapo, try the Tapo integration in ST.

to link Kasa to Tapo… download/login to the Tapo app, tap on Me in lower menu and select Link Tapo with Kasa.

Yes I removed the disconnected integration many times

Started from:

Add a new device → TP Link Kasa

Login fails, then the disconnected integration comes back after failed login.

1 Like

I get the same error when when I try ti link ST and Kasa. Two suggestions:

  1. If you have a ST hub use the Kasa Edge Drive to bring you Kasa devices into ST. No account linking is needed.

  2. Import you Kasa devices into the Tapo app and try linking the Tapo App with ST.

Thank you both for the Tapo suggestion

I was able to link Tapo and Kasa and all my devices show in Tapo.
I was also able to link Tapo to ST, however no devices show up.

I tried the Kasa Edge Driver earlier today but its very laggy with intermittent responses and devices randomly showing offline.

I deleted the driver and all the devices that it imported.

Same problem for me. My Kasa devices were working a few weeks through Smarthings and now don’t. When I try to reconnect to Tplink Kasa I too get bad request. Tried multiple things cannot get it working.

I just tried the Tapo integration and got the same results. None of my 8 Kasa devices came over to ST.

I have been using the Kasa Edge Driver for 13 months without any significant issues since the early Beta days when Barry was working out the kinks. I would retry to Edge Driver and and try rebooting you ST hub after all the Kasa devices are discovered to see if that helps.

They fixed the API

I was just able to login and link Kasa and ST

I made support tickets on both platforms but haven’t heard anything

It’s working though

Thanks all for the suggestions