TP Link Kasa Dropping Out?

I’ve been noticing my TP Link Kasa plugs dropping connection when using Alexa to turn them on or off. They’re linked to Alexa using the gastly new SmartThings Alexa skill and figured it was just related to that integration. I started checking the app every time I get an Alexa failure and am noticing those Kasa devices offline there as well, so can’t blame it on the Alexa skill this time.
Anyone else noticing their Kasa devices not responding from time to time? They were always solid for me in the past, so not sure what changed?

Not using Alexa but Google will do the same thing. My issues have been signal related or a power failure however. Not sure if this really helps you out…

1 Like

Have you checked the status of the Kasa Cloud when these errors are occurring? Link:

Also check your past logs for the Alexa Skill for error conditions.


I wasn’t aware that TP Link had a status page. Thank you! I have it bookmarked now.

I experienced the problem again today with my Google Mini. Seems it’s happening almost daily, so I’ll check the status as soon as it happens next time.

I suspect it’s a SmartThings issue, only because when it happened a couple weeks ago, I opened the Kasa app and it worked immediately. Time for more testing…

Can you advise where these logs are? I’m not finding them in the IDE, new app, nor the Alexa app.

Had another Kasa failure this morning with Alexa and the app. Opened the Kasa app and the light worked right away. No reported Kasa outage either.

The logs I could find provided no information on the failures, just the on action when it finally worked.

Need someone else to discuss this. Looking for Past Logs for devices.

1 Like

It’s another day and another Kasa outage for me. So very weird! Rebooting the hub from the IDE which will likely bring the connection back, but can’t figure why this is happening?
I’ll likely try switching the internet band to 2.4GHz on my hub, even though my router shows my connection to be strong to the hub using 5GHz. Maybe, just maybe it’s dropping out at times.

We have a similar issue. We had been using kasa plugs with Google home for a while without issue.

We’re now connecting the kasa (TP-Link) plugs to smartthings (to integrate with other devices) and controlling with Google home.

Recently the kasa devices stop responding. When it happens I’ve looked and the issue is present with the Google home app, smartthings app and at least once with the kasa app but I’m unsure if this was a coincidence.

Will keep an eye out next time it happens.

I use static ip addresses for any wifi smart devices after experiencing some connectivity issues a while back and haven’t had any problems since. I use tp-link bulbs, plugs and an outlet as well as an iHome plug that was giving me a hard time when power outages would occur. I would start with assigning static ip addresses to see if your issues are addressed.

That’s a good suggestion that I had setup in the past, but don’t currently.

I may have found “a fix” of sorts by trial and error. I have several Kasa plugs, but only had 2 hooked up for lamps. I recently moved and am piecing my system together. I decided to swap out a troubled plug with a Zigbee bulb not in use. That seemed to work ok. I renamed the bulb to the same thing as the plug dropping frequently. I then renamed the troubled Kasa plug and put it on a different lamp. No further problems yet.

What seems to have fixed the setup is renaming the plug. I don’t know why, but it seems to have forced a refresh of sorts. I’ll update this thread if this holds out as a solution.

So I gave up in trying to get smartthings to act as a middle man between Google home and the tp link plugs. Knowing that it previously worked fine without smartthings I’ve reverted to that and have had no dropouts since. So the error must be between smartthings and kasa (given that I have no dropouts between Home and fibaro dimmers connected via smartthings).

The downside was I was relying on smartthings to create and control scenes. Now it’s a messy mix of virtual rooms to get the desired actions to work.

1 Like